Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48247 - syslinux-6.03-4 breaks archiso

Attached to Project: Arch Linux
Opened by Jeff Hodd (jghodd) - Friday, 19 February 2016, 02:50 GMT
Last edited by Anatol Pomozov (anatolik) - Saturday, 20 February 2016, 19:05 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Pierre Schmitz (Pierre)
Anatol Pomozov (anatolik)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

The latest release of syslinux - v6.03-4 - breaks archiso builds, making them unbootable. On boot, the system displays "ISOLINUX 6.03 6.03* EHDD" and hangs.

I noticed the breakage yesterday after an archiso build that downloaded the most recent syslinux package version. I had been building for the 3 days prior to yesterday without any issues. None of the configuration changed between builds since I'm working on detailing the kde installation. Today, I repackaged syslinux-6.03-3 as syslinux-6.03-5 and loaded into my own testing repo - the issue went away after an archiso build using the repackaged syslinux-6.03-3. The problem is definitely with the '-4' version.

Additional info:
* package version(s)
- 6.03-4

* config and/or log files etc.


Steps to reproduce:

Create an arch iso build using archiso - try to boot it up. It errors out with the message "ISOLINUX 6.03 6.03* EHDD" and hangs.
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Saturday, 20 February 2016, 19:05 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#48253 
Comment by Philip Müller (philm) - Saturday, 20 February 2016, 08:35 GMT Comment by Philip Müller (philm) - Saturday, 20 February 2016, 10:39 GMT
The btrfs boot patch is the issue. Please use a newer git-snapshot instead.
Comment by Jeff Hodd (jghodd) - Saturday, 20 February 2016, 18:16 GMT
Thanks, Phillip. I'm building it now with the commit you're using (c1cc1bcef1e23ecb9f650c75f9dafc7e61101218). I'll leave another comment after testing it.

Is it possible that the original git-snapshot for -4 might also work by simply ignoring the btrfs fix patch?
Comment by Jeff Hodd (jghodd) - Saturday, 20 February 2016, 18:55 GMT
Phillip - you might also want to chime in over at https://bugs.archlinux.org/task/48253

I also posted this bug as an archiso issue, which attracted the attention of the package maintainers, who I've engaged in a thread under that task number.
Comment by Anatol Pomozov (anatolik) - Saturday, 20 February 2016, 19:02 GMT
Philip when you say "use a newer git-snapshot instead" do you mean use syslinux HEAD where the boot problem does not exist?

Loading...