Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48214 - [syslinux] Hangs after displaying copyright notice when installed on Btrfs

Attached to Project: Arch Linux
Opened by Daniel Milewski (niitotantei) - Tuesday, 16 February 2016, 19:47 GMT
Last edited by Anatol Pomozov (anatolik) - Wednesday, 17 February 2016, 17:37 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Anatol Pomozov (anatolik)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
SYSLINUX hangs after displaying copyright notice when installed on Btrfs. I think it's related to a change in mkfs.btrfs, because I was able to create working setups with previous versions of btrfs-progs.

This issue is already fixed in upstream[1], and I can confirm that the latest Git revision[2] works as expected, as I've tested it. I ask for fix to be included in Arch because it looks like 6.04 wouldn't be released soon (as we don't even have a prerelease version at the moment.)

Additional info:
I'm using a single disk (/dev/vda), and my /etc/fstab file looks like this:

/dev/vda1 / btrfs defaults
/dev/vda2 none swap defaults

Steps to reproduce:
Install SYSLINUX on a system where /boot is located on a Btrfs filesystem.

[1] http://repo.or.cz/syslinux.git/commit/548386049cd41e887079cdb904d3954365eb28f3
[2] http://repo.or.cz/syslinux.git/commit/875001667b9cbb1af421ce3e84feb8ce548dc5e4
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Wednesday, 17 February 2016, 17:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  syslinux-6.03-4
Comment by Anatol Pomozov (anatolik) - Wednesday, 17 February 2016, 07:07 GMT
syslinux-6.03-4 with this btrfs fix is pushed to [testing]. Please verify that it fixes your issue.
Comment by Daniel Milewski (niitotantei) - Wednesday, 17 February 2016, 12:23 GMT
It works perfectly well :). Please move it from [testing] to [core], and thanks for fixing this!

Loading...