Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#48183 - makepkg --pkg option gone?

Attached to Project: Pacman
Opened by Xyne (Xyne) - Sunday, 14 February 2016, 19:20 GMT
Last edited by Allan McRae (Allan) - Sunday, 14 February 2016, 20:21 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 5.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It seems that the makepkg --pkg option to select which package to install from a split package has been silently(?) removed.

If intentional, what is the new way of doing it?
If not, I hope that a fix can be pushed through quickly.
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 14 February 2016, 20:21 GMT
Reason for closing:  Not a bug
Comment by Andrew Gregory (andrewgregory) - Sunday, 14 February 2016, 19:39 GMT
Silent? https://projects.archlinux.org/pacman.git/tree/NEWS#n40

makepkg no longer provides a way to build (or install) individual packages from a split PKGBUILD. See the discussion starting with https://lists.archlinux.org/pipermail/pacman-dev/2015-September/020347.html for the reasoning behind the removal.

Loading...