Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48158 - [gtk3] Firefox crashes while saving file to save dialog search result

Attached to Project: Arch Linux
Opened by John C (tancrackers) - Friday, 12 February 2016, 20:18 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 16 February 2016, 09:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Evangelos Foutras (foutrelis)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Firefox crashes everytime under a specific situation.
It involves the save dialog, and I believe this to be an issue with DE integration and the Arch Linux build.

Here is how to reproduce the crash:
Go to save a webpage, opening the save dialog in Firefox. Use Ctrl+F to open up the search dialog. Type a name into the search bar and go to save the file. Firefox will crash.

I downloaded Firefox from the Mozilla website and compared the binary to the Arch version.
The Mozilla build did not crash because it did not integrate a file search; it just gave me a list of items inside the current directory.

Linux 4.4.1-2-ARCH
Plasma 5.5.4-1
Firefox 44.0.2-1

Link to Mozilla bug for reference, but it should not be relevant:
https://bugzilla.mozilla.org/show_bug.cgi?id=1247840

Screenshot to save dialog in Firefox (Mozilla build):
https://i.imgur.com/DLH04Ue.png

Screenshot to save dialog search results in Firefox (Arch build):
https://i.imgur.com/CPamqm3.png
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 16 February 2016, 09:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtk3 3.18.7-2
Comment by Evangelos Foutras (foutrelis) - Friday, 12 February 2016, 22:38 GMT
gedit crashes in the same way so it looks like a bug in GTK3.
Comment by John C (tancrackers) - Friday, 12 February 2016, 22:53 GMT
Here is the konsole log:
[john@john-archlinux ~]$ gedit

(gedit:23957): Gtk-CRITICAL **: _gtk_file_system_model_get_info: assertion 'GTK_IS_FILE_SYSTEM_MODEL (model)' failed
**
Gtk:ERROR:gtkfilechooserwidget.c:6280:get_display_name_from_file_list: assertion failed: (info != NULL)
Aborted (core dumped)
[john@john-archlinux ~]$
The same goes for Firefox.
Comment by Evangelos Foutras (foutrelis) - Friday, 12 February 2016, 23:15 GMT

Loading...