Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48135 - [linux] kernel 4.4.x breaks ext4 data mount option on LVM volumes

Attached to Project: Arch Linux
Opened by Georg (georgnix) - Thursday, 11 February 2016, 10:01 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 11 February 2016, 15:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After upgrading linux (4.3.3-3 -> 4.4.1-2) ext4 file system on lvm with mount option data=ordered fails to mount.

# mount /home
mount: wrong fs type, bad option, bad superblock on /dev/mapper/gurke-home,
missing codepage or helper program, or other error

In some cases useful info is found in syslog - try
dmesg | tail or so.

syslog:
systemd[1]: Failed to mount /home.
kernel: EXT4-fs (dm-1): can't mount with data=, fs mounted w/o journal

/etc/fstab:
# root file system is mounted despite data=ordered
UUID=a884660a-ce6e-4bd6-8c06-589647c41922 / ext4 rw,discard,relatime,data=ordered 0 1

# causes mount error:
/dev/mapper/gurke-home /home ext4 rw,discard,relatime,data=ordered 0 2
# without data=ordered filesystem is mounted
#/dev/mapper/gurke-home /home ext4 rw,discard,relatime 0 2


Removing the data=ordered mount option for /home resolves the mount failure.

/home and / are both LVM volumes:
# blkid | grep '\(root\|home\)'
/dev/mapper/gurke-root: LABEL="root" UUID="a884660a-ce6e-4bd6-8c06-589647c41922" TYPE="ext4"
/dev/mapper/gurke-home: LABEL="home" UUID="c63fb436-16ce-44b1-9082-c0c99ffa9cd9" TYPE="ext4"



Remark:
*Is this a bug in the arch systemd unit files or a problem in the kernel?*

This bug affects at least two different users:
https://bbs.archlinux.org/viewtopic.php?id=208425

Additional info:
* package version(s)
upgraded upgrading linux (4.3.3-3 -> 4.4.1-2)

* config and/or log files etc.

/var/log/pacman.log:
[2016-02-11 10:01] [PACMAN] Running 'pacman -Suy'
[2016-02-11 10:01] [PACMAN] synchronizing package lists
[2016-02-11 10:01] [PACMAN] starting full system upgrade
[2016-02-11 10:05] [ALPM] transaction started
[2016-02-11 10:05] [ALPM] upgraded arb (2.8.0-1 -> 2.8.1-1)
[2016-02-11 10:05] [ALPM] upgraded libcap (2.24-2 -> 2.25-1)
[2016-02-11 10:05] [ALPM] upgraded bind-tools (9.10.3.P3-1 -> 9.10.3.P3-3)
[2016-02-11 10:05] [ALPM] upgraded gnutls (3.4.8-1 -> 3.4.9-1)
[2016-02-11 10:05] [ALPM] upgraded v4l-utils (1.6.3-3 -> 1.10.0-1)
[2016-02-11 10:05] [ALPM] upgraded libgcrypt (1.6.4-1 -> 1.6.5-1)
[2016-02-11 10:05] [ALPM] upgraded kmod (21-2 -> 22-1)
[2016-02-11 10:05] [ALPM] upgraded libsystemd (228-3 -> 228-4)
[2016-02-11 10:05] [ALPM] upgraded coreutils (8.24-1 -> 8.25-1)
[2016-02-11 10:05] [ALPM] upgraded systemd (228-3 -> 228-4)
[2016-02-11 10:05] [ALPM] upgraded libsndfile (1.0.25-3 -> 1.0.26-1)
[2016-02-11 10:05] [ALPM] upgraded freetype2 (2.6.2-1 -> 2.6.3-1)
[2016-02-11 10:05] [ALPM] upgraded giflib (5.1.1-1 -> 5.1.2-1)
[2016-02-11 10:05] [ALPM] upgraded chromaprint (1.2-2 -> 1.3-1)
[2016-02-11 10:05] [ALPM] upgraded libcups (2.1.2-3 -> 2.1.3-1)
[2016-02-11 10:05] [ALPM] upgraded chromium (48.0.2564.97-1 -> 48.0.2564.103-1)
[2016-02-11 10:05] [ALPM] upgraded cups (2.1.2-3 -> 2.1.3-1)
[2016-02-11 10:05] [ALPM] upgraded firefox (44.0-2 -> 44.0.1-1)
[2016-02-11 10:05] [ALPM] upgraded flashplugin (11.2.202.559-1 -> 11.2.202.569-1)
[2016-02-11 10:05] [ALPM] upgraded gdal (2.0.1-6 -> 2.0.2-1)
[2016-02-11 10:05] [ALPM] upgraded gedit (3.18.2-1 -> 3.18.3-1)
[2016-02-11 10:05] [ALPM] upgraded git (2.7.0-1 -> 2.7.1-1)
[2016-02-11 10:05] [ALPM] upgraded vim-runtime (7.4.1190-1 -> 7.4.1294-1)
[2016-02-11 10:05] [ALPM] upgraded gvim (7.4.1190-1 -> 7.4.1294-1)
[2016-02-11 10:05] [ALPM] upgraded lib32-libcap (2.24-1 -> 2.25-1)
[2016-02-11 10:05] [ALPM] upgraded lib32-libsndfile (1.0.25-3 -> 1.0.26-1)
[2016-02-11 10:05] [ALPM] upgraded libbsd (0.8.2-1 -> 0.8.2-2)
[2016-02-11 10:05] [ALPM] upgraded libburn (1.4.2-1 -> 1.4.2.pl01-1)
[2016-02-11 10:05] [ALPM] upgraded libgsf (1.14.34-1 -> 1.14.35-1)
[2016-02-11 10:05] [ALPM] upgraded libical (2.0.0-1 -> 2.0.0-2)
[2016-02-11 10:05] [ALPM] upgraded libinput (1.1.5-1 -> 1.1.6-1)
[2016-02-11 10:05] [ALPM] upgraded libreoffice-still (4.4.7-3 -> 4.4.7-4)
[2016-02-11 10:05] [ALPM] upgraded libwnck3 (3.14.0-1 -> 3.14.1-1)
[2016-02-11 10:05] [ALPM] warning: /etc/lightdm/lightdm.conf installed as /etc/lightdm/lightdm.conf.pacnew
[2016-02-11 10:05] [ALPM] upgraded lightdm (1:1.16.7-1 -> 1:1.16.7-3)
[2016-02-11 10:06] [ALPM] upgraded linux (4.3.3-3 -> 4.4.1-2)
[2016-02-11 10:06] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2016-02-11 10:06] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio. Please wait...
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Starting build: 4.4.1-2-ARCH
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [systemd]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [sd-lvm2]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Image generation successful
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Starting build: 4.4.1-2-ARCH
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [systemd]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [sd-lvm2]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2016-02-11 10:06] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Image generation successful
[2016-02-11 10:06] [ALPM] upgraded linux-headers (4.3.3-3 -> 4.4.1-2)
[2016-02-11 10:06] [ALPM] upgraded lirc (1:0.9.3.a-1 -> 1:0.9.3.a-2)
[2016-02-11 10:06] [ALPM] upgraded lvm2 (2.02.138-1 -> 2.02.141-1)
[2016-02-11 10:06] [ALPM] upgraded mathjax (2.6.0-1 -> 2.6.1-1)
[2016-02-11 10:06] [ALPM] upgraded owncloud-client (2.1.0-2 -> 2.1.1-1)
[2016-02-11 10:06] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2016-02-11 10:06] [ALPM] upgraded pacman-mirrorlist (20160124-1 -> 20160208-2)
[2016-02-11 10:06] [ALPM] upgraded protobuf-c (1.1.1-2 -> 1.2.1-2)
[2016-02-11 10:06] [ALPM] upgraded pv (1.6.0-1 -> 1.6.0-2)
[2016-02-11 10:06] [ALPM] upgraded python-packaging (16.0-1 -> 16.2-1)
[2016-02-11 10:06] [ALPM] upgraded python-scipy (0.16.1-2 -> 0.17.0-1)
[2016-02-11 10:06] [ALPM] upgraded python-setuptools (1:19.7-1 -> 1:20.0-1)
[2016-02-11 10:06] [ALPM] upgraded python2-packaging (16.0-1 -> 16.2-1)
[2016-02-11 10:06] [ALPM] upgraded python2-rpy2 (2.7.7-1 -> 2.7.8-1)
[2016-02-11 10:06] [ALPM] upgraded python2-scipy (0.16.1-2 -> 0.17.0-1)
[2016-02-11 10:06] [ALPM] upgraded python2-setuptools (1:19.7-1 -> 1:20.0-1)
[2016-02-11 10:06] [ALPM] upgraded recoll (1.21.4-1 -> 1.21.5-1)
[2016-02-11 10:06] [ALPM] upgraded systemd-sysvcompat (228-3 -> 228-4)
[2016-02-11 10:06] [ALPM] installed libsynctex (2015.37497-10)
[2016-02-11 10:06] [ALPM] upgraded texlive-bin (2015.37497-9 -> 2015.37497-10)
[2016-02-11 10:06] [ALPM-SCRIPTLET] >>> texlive: updating the filename database...
[2016-02-11 10:06] [ALPM] upgraded virtualbox-host-dkms (5.0.12-1 -> 5.0.14-1)
[2016-02-11 10:06] [ALPM-SCRIPTLET]
[2016-02-11 10:06] [ALPM-SCRIPTLET] Creating symlink /var/lib/dkms/vboxhost/5.0.14/source ->
[2016-02-11 10:06] [ALPM-SCRIPTLET] /usr/src/vboxhost-5.0.14
[2016-02-11 10:06] [ALPM-SCRIPTLET]
[2016-02-11 10:06] [ALPM-SCRIPTLET] DKMS: add completed.
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> Remember to upgrade your running modules
[2016-02-11 10:06] [ALPM-SCRIPTLET] ==> You can do this running vboxreload command as root
[2016-02-11 10:06] [ALPM] upgraded virtualbox-host-modules (5.0.12-2 -> 5.0.14-3)
[2016-02-11 10:06] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2016-02-11 10:06] [ALPM-SCRIPTLET] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2016-02-11 10:06] [ALPM] upgraded virtualbox-ext-vnc (5.0.12-1 -> 5.0.14-1)
[2016-02-11 10:06] [ALPM-SCRIPTLET] 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
[2016-02-11 10:06] [ALPM] upgraded virtualbox-guest-iso (5.0.12-1 -> 5.0.14-1)
[2016-02-11 10:06] [ALPM] upgraded zsh-completions (0.12.0-2 -> 0.14.0-2)
[2016-02-11 10:06] [ALPM] upgraded zsh-lovers (0.9.0-1 -> 0.9.0-2)
[2016-02-11 10:06] [ALPM] transaction completed

Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 11 February 2016, 15:56 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Config issue
Comment by Gerardo Exequiel Pozzi (djgera) - Thursday, 11 February 2016, 12:59 GMT
> *Is this a bug in the arch systemd unit files or a problem in the kernel?*
The answer is in kernel message: "can't mount with data=, fs mounted w/o journal".

If your FS does not have a journal => *not a bug*, otherwise is a bug in the ext4 driver (the new code says: if you don not have a journal in the filesystem, why are you passing arguments to set options about it, of course does not make sense). [713009809681e5a7871e96e6992692c805b4480b]
Comment by Nikola Kotur (kotnik) - Thursday, 11 February 2016, 13:06 GMT
This is not a bug. Passing journal options to a file system that has no journal made no sense anyway. Now it's just a hard fail.

Either remove mount options, or add a journal (tune2fs -j /dev/fs).
Comment by Georg (georgnix) - Thursday, 11 February 2016, 15:52 GMT
Thanks to Nikola and Gerardo. I did not understand the error message from the kernel "can't mount with data=, fs mounted w/o journal".
The fs had no journal indeed (to my surprise).
The message is not terribly clear on the other hand. IMHO
"can't mount with data option, fs has no journal" would be better. What do you think?

github url for the commit:
https://github.com/torvalds/linux/commit/713009809681e5a7871e96e6992692c805b4480b

Loading...