Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48089 - wiki create account page

Attached to Project: Arch Linux
Opened by brian downing (bsd) - Monday, 08 February 2016, 12:00 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 09 February 2016, 19:49 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The Wiki Create User Page [1] asks command line question for uninstalled command
[1]:https://wiki.archlinux.org/index.php/Special:UserLogin/signup

Asks captcha like question
What is the output of "pacman -V|base32|head -1"

Which, on my system (pacman v5.0.0, kernel 4.4.1-2-ARCH) replies
-bash: base32: command not found
(not the answer form was looking for)

$ sudo pacman -Ss base32
community/perl-mime-base32 1.02-1 [installed]
Base32 encoder / decoder

And, there is no rotation (ask me a different question)
I had to use the perl-mime-base32 to write a perl script to be able to answer the question, so I create an account, login and report this.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
Logout, try creating new user
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 09 February 2016, 19:49 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Tuesday, 09 February 2016, 03:01 GMT
Known issue, currently requires coreutils from the testing repo.
Comment by brian downing (bsd) - Tuesday, 09 February 2016, 09:55 GMT
Since base64 seems to be included with core/coreutils
why doesn't someone simply change the test from base32 to base64?
Comment by Pierre Schmitz (Pierre) - Tuesday, 09 February 2016, 17:53 GMT
No idea why this package is still in testing. As I don't have much time right now, I have changed the captcha to base64.
Comment by brian downing (bsd) - Tuesday, 09 February 2016, 18:03 GMT
Thanks, tested, works.
Requested closure

Loading...