Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48073 - [jack2-dbus] Can't start jackdbus anymore for internal device since kernel 4.4

Attached to Project: Community Packages
Opened by Johannes Maibaum (jmx) - Sunday, 07 February 2016, 15:26 GMT
Last edited by Ray Rashif (schivmeister) - Saturday, 05 March 2016, 00:51 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ray Rashif (schivmeister)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
I discovered yesterday that I cannot start the jack server (installed from jack2-dbus) anymore when running on the current Linux 4.4.1-2 kernel package.
My first suspect was the recent pulseaudio update to version 8.0 but downgrading to 7.1 did not help. But, downgrading the Linux kernel to 4.3.3-3, I can start jack again.

When on kernel 4.4, I get the following messages from Qjackctl while trying to start jack using the alsa driver (using the dummy driver it still works):

Sun Feb 7 15:02:32 2016: Starting jack server...
Sun Feb 7 15:02:32 2016: JACK server starting in realtime mode with priority 10
Sun Feb 7 15:02:32 2016: self-connect-mode is "Don't restrict self connect requests"
Sun Feb 7 15:02:32 2016: Acquired audio card Audio0
Sun Feb 7 15:02:32 2016: creating alsa driver ... hw:NVidia|hw:NVidia|512|2|48000|0|0|nomon|swmeter|-|32bit
Sun Feb 7 15:02:33 2016: configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 2 periods
Sun Feb 7 15:02:33 2016: ALSA: final selected sample format for capture: 32bit integer little-endian
Sun Feb 7 15:02:33 2016: ALSA: use 2 periods for capture
Sun Feb 7 15:02:33 2016: ALSA: final selected sample format for playback: 32bit integer little-endian
Sun Feb 7 15:02:33 2016: ALSA: use 2 periods for playback
Sun Feb 7 15:02:38 2016: ERROR: JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Sun Feb 7 15:02:38 2016: ERROR: Driver is not running
Sun Feb 7 15:02:38 2016: ERROR: Cannot open client name = dbusapi
Sun Feb 7 15:02:38 2016: ERROR: failed to create dbusapi jack client
Sun Feb 7 15:02:38 2016: ERROR: Unknown request 4294967295
Sun Feb 7 15:02:38 2016: ERROR: CheckSize error size = 0 Size() = 12
Sun Feb 7 15:02:38 2016: ERROR: CheckRead error

I started a forum thread for this issue yesterday, which I link here for reference:

https://bbs.archlinux.org/viewtopic.php?id=208567
This task depends upon

Closed by  Ray Rashif (schivmeister)
Saturday, 05 March 2016, 00:51 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Sunday, 07 February 2016, 21:00 GMT
What version of jack2-dbus?
Comment by Bruno Santos (bms) - Sunday, 07 February 2016, 21:12 GMT
I can replicate the issue with:
core/linux 4.4.1-2
community/jack2-dbus 1.9.10-3
extra/pulseaudio-jack 8.0-1
Comment by Johannes Maibaum (jmx) - Sunday, 07 February 2016, 21:56 GMT
Sorry, I forgot the version numbers.
I'm on
core/linux 4.4.1-2
community/jack2-dbus 1.9.10-3
extra/pulseaudio-jack 8.0-1
as well.
Comment by Johannes Maibaum (jmx) - Monday, 08 February 2016, 08:04 GMT
As suggested in the forum, I also reported the issue upstream, see https://github.com/jackaudio/jack2/issues/186 .
Comment by Ray Rashif (schivmeister) - Monday, 08 February 2016, 21:20 GMT
  • Field changed: Summary ([jack2-dbus] Can't start jack anymore since kernel 4.4 → [jack2-dbus] Can't start jackdbus anymore for internal device since kernel 4.4)
  • Field changed: Severity (High → Medium)
I've updated the description to include jackdbus instead, since you reported jackd to work in some way and success with an external device. Anyone else reproducing this issue please post hardware details.
Comment by Johannes Maibaum (jmx) - Wednesday, 10 February 2016, 15:04 GMT
I've just posted this issue to the alsa-user mailing list: http://article.gmane.org/gmane.linux.alsa.user/39426 Inside, I've also posted a link to the output of the alsa-info.sh script from my machine: http://www.alsa-project.org/db/?f=4f288b556984d50e322fc85d2cfd73fb03b7e0cd
Comment by Johannes Maibaum (jmx) - Tuesday, 23 February 2016, 13:50 GMT
Just to clarify, the issue occurs using both the dbus interface to jack2 as well as the jackd command. As soon as I try to a capture mode, it fails.

I'm still hoping to get a reply from the ALSA guys, if this might be a problem on the HDA driver side. Up until now, they did not respond.

But the issue still must be closely related to jack2/jack2-dbus as I did not face any problems with non-JACK audio applications.
Comment by Ray Rashif (schivmeister) - Wednesday, 02 March 2016, 22:54 GMT
Curious -- did you ever try troubleshooting this with jack1? Please do that if you haven't (don't use jackd of jack2).
Comment by Johannes Maibaum (jmx) - Thursday, 03 March 2016, 09:18 GMT
Hi Ray,

I can report some news. It seems by now that the bug was *not* due to some regression in the kernel and/or jack, but due to some misconfigurations on my side. Last weekend, I have tried various different live Linux distributions with a recent kernel (4.3 and 4.4 were among them) and all of them worked.

So, at one point I decided to give it a go and do a full reinstall of my Arch System and sure enough, the problem was gone. I have since then tested both jack1 and jack2 (with both the old jackd and the jackdbus interface) and all of them seem to work as expected in all modes.

I am really curious what was wrong configuration-wise before the reinstall. But, at the moment it seems that there never was a real bug, only stupid misconfiguration introduced by me. I will keep observing jack and see if the problem reoccurs at one point, as I am slowly reinstalling packages that I had been using before the reinstall, but until now I have no problems any more.
Comment by Ray Rashif (schivmeister) - Thursday, 03 March 2016, 13:29 GMT
Could you not have tested this by creating a new user with a fresh environment? Maybe you did, and perhaps the problem is somewhere else, but you won't know until you recreate the state you were in last.

We can't yet close this because someone else above has reported to have been able to reproduce this. Bruno, any comments?
Comment by Bruno Santos (bms) - Thursday, 03 March 2016, 21:25 GMT
I just tried it again and the problem persists.

Now, due to an unrelated issue where I wrote over my system partition by mistake (not funny..), I reinstalled the whole system quite recently, and I still have the problem, BUT I have scripts and what not so I just installed jack and recovered the bad settings whichever they were in the same (semi-)automated way.

However, this is good news! Assuming Johannes is right, I only have to figure out which of my personal changes introduced the problem.
I wouldn't call it stupid misconfiguration just yet though... My setup was working fine for a very long time with this configuration.

Give me until this weekend, I'll try to look into it.
Comment by Bruno Santos (bms) - Friday, 04 March 2016, 21:19 GMT
Good news everyone! Well.. sort of.

I can't replicate the issue any more.
The error I was getting now was slightly different and I did know exactly where it came from: not setting the hardware device explicitly.
A bit of configuration work I commented out in my install script for some reason.

I'm quite happy closing this one.

Loading...