Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48055 - [libsndfile] python2 is a makedepend, not a checkdepend

Attached to Project: Arch Linux
Opened by Kevin Mihelich (kmihelich) - Saturday, 06 February 2016, 07:22 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 29 September 2018, 08:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: python2 is required for the build process to generate the symbol files, and should be listed as a makedepend. If built with --nocheck, building the package will fail.


Additional info:
* package version: 1.0.26-1
* log snippet:
config.status: creating src/Makefile
config.status: executing depfiles commands
python2 ./create_symbols_file.py linux 1.0.26 > Symbols.gnu-binutils
/bin/sh: python2: command not found
Makefile:1156: recipe for target 'Symbols.gnu-binutils' failed
make: *** [Symbols.gnu-binutils] Error 127
make: Nothing to be done for 'genfiles'


Steps to reproduce: Build with --nocheck.
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 29 September 2018, 08:42 GMT
Reason for closing:  Works for me
Additional comments about closing:  Python no longer needed (even for tests)
Comment by Kevin Mihelich (kmihelich) - Saturday, 02 July 2016, 00:46 GMT
Affects 1.0.27-1 as well.

Loading...