Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#48028 - [liblphobos] may need a -devel version

Attached to Project: Community Packages
Opened by Yannick Koechlin (yawniek) - Thursday, 04 February 2016, 10:37 GMT
Last edited by Dan Printzell (Wild) - Wednesday, 24 January 2018, 10:53 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Dan Printzell (Wild)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I can't compile dub debug releases:



Additional info:
* package version(s)
* config and/or log files etc.

ws02% pacman -Q | grep ldc
ldc 1:0.16.1-4



ws02% ldc --version
LDC - the LLVM D compiler (0.16.1):
based on DMD v2.067.1 and LLVM 3.7.1
Default target: x86_64-unknown-linux-gnu
Host CPU: haswell
http://dlang.org - http://wiki.dlang.org/LDC

Registered Targets:
aarch64 - AArch64 (little endian)
aarch64_be - AArch64 (big endian)
amdgcn - AMD GCN GPUs
arm - ARM
arm64 - ARM64 (little endian)
armeb - ARM (big endian)
bpf - BPF (host endian)
bpfeb - BPF (big endian)
bpfel - BPF (little endian)
cpp - C++ backend
hexagon - Hexagon
mips - Mips
mips64 - Mips64 [experimental]
mips64el - Mips64el [experimental]
mipsel - Mipsel
msp430 - MSP430 [experimental]
nvptx - NVIDIA PTX 32-bit
nvptx64 - NVIDIA PTX 64-bit
ppc32 - PowerPC 32
ppc64 - PowerPC 64
ppc64le - PowerPC 64 LE
r600 - AMD GPUs HD2XXX-HD6XXX
sparc - Sparc
sparcel - Sparc LE
sparcv9 - Sparc V9
systemz - SystemZ
thumb - Thumb
thumbeb - Thumb (big endian)
x86 - 32-bit X86: Pentium-Pro and above
x86-64 - 64-bit X86: EM64T and AMD64
xcore - XCore


ws02% dub --version
DUB version 0.9.24+95-g20d74e8, built on Jan 5 2016

Steps to reproduce:
ws02% dub init -t vibe.d ugah
Successfully created an empty project in '/home/yannick/code/d/test/ugah'.
ws02% cd ugah
ws02% ls
dub.json public source views
ws02% dub build --compiler=ldc
Performing "debug" build using ldc for x86_64.
vibe-d:utils 0.7.27: building configuration "library"...
vibe-d:data 0.7.27: building configuration "library"...
vibe-d:core 0.7.27: building configuration "libevent"...
vibe-d:http 0.7.27: building configuration "library"...
hvibe-d:diet 0.7.27: building configuration "library"...
vibe-d:mail 0.7.27: building configuration "library"...
vibe-d:mongodb 0.7.27: building configuration "library"...
vibe-d:redis 0.7.27: building configuration "library"...
vibe-d:web 0.7.27: building configuration "library"...
vibe-d 0.7.27: building configuration "libevent"...
ugah ~master: building configuration "application"...
/usr/include/dlang/ldc/std/digest/sha.d:224: error: undefined reference to '_D3std8internal6digest9sha_SSSE314transformSSSE3FNaNbNiPG5kPxG64hZv'
/usr/include/dlang/ldc/std/digest/sha.d:224: error: undefined reference to '_D3std8internal6digest9sha_SSSE314transformSSSE3FNaNbNiPG5kPxG64hZv'
/usr/include/dlang/ldc/std/digest/sha.d:224: error: undefined reference to '_D3std8internal6digest9sha_SSSE314transformSSSE3FNaNbNiPG5kPxG64hZv'
/usr/include/dlang/ldc/std/digest/sha.d:224: error: undefined reference to '_D3std8internal6digest9sha_SSSE314transformSSSE3FNaNbNiPG5kPxG64hZv'
collect2: error: ld returned 1 exit status
Error: /usr/sbin/gcc failed with status: 1
ldc failed with exit code 1.


This task depends upon

Closed by  Dan Printzell (Wild)
Wednesday, 24 January 2018, 10:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  It was fixed upstream a while back
Comment by Mihails Strasuns (Dicebot) - Sunday, 07 February 2016, 05:58 GMT
Ok, figured out that SSSE3 support is intentionally disabled for shared libraries because of https://issues.dlang.org/show_bug.cgi?id=9378
Not sure how to proceed as there doesn't seem to be obvious way to switch between static and shared library in LDC even if I build/package both. Will ask upstream.
Comment by Mihails Strasuns (Dicebot) - Tuesday, 09 February 2016, 12:31 GMT
Still waiting on upstream feedback : https://github.com/ldc-developers/ldc/issues/1282

Loading...