Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47997 - [linux] Haswell graphics break: sna_mode_shutdown_crtc: invalid state found on pipe 0

Attached to Project: Arch Linux
Opened by John (graysky) - Tuesday, 02 February 2016, 22:18 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 23 March 2016, 16:49 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

4.4.1-1-custom causes breakage of Xorg where the monitor goes to sleep but does not wake up from the sleep state. I have to `systemctl restart display-manager` in order to revive the Xorg display. I attached my full /var/log/Xorg.log but the error is shown below:

(EE) intel(0): sna_mode_shutdown_crtc: invalid state found on pipe 0, disabling CRTC:21

Note - My only modification to the standard ARCH package is the tick rate which I have increased to 1000 Hz. I can verify that the official package causes this if needed.

Additional info:
* package version(s) 4.4.1-ARCH
* Hardware is an Intel i7-4790K using the onboard graphics chip with no modifications to /etc/X11/*

Steps to reproduce:
Allow monitor to go to sleep and attempt to wake it.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 23 March 2016, 16:49 GMT
Reason for closing:  None
Additional comments about closing:  Continued in  FS#48647 
Comment by John (graysky) - Wednesday, 03 February 2016, 21:02 GMT Comment by John (graysky) - Friday, 05 February 2016, 21:48 GMT
Upstream requested that the bug get re-designated: https://bugs.freedesktop.org/show_bug.cgi?id=94014
Comment by Javier (jevv) - Sunday, 14 February 2016, 20:31 GMT
Are you using early KMS? If so, have you tried rebuilding the mkinitcpio initrd image? Finally, if so, have you tried not to do early KMS (meaning not loading the i915 module on the mkinitcpio initrd image)?

I'm having problems with hdmi negotiation reolution, and was having this graphics issue of not waking up, but lately I don't see the waking up issue, but more often the hdmi negotiation resolution (on wake up)...

See https://bugs.archlinux.org/task/48086.
Comment by John (graysky) - Sunday, 14 February 2016, 20:40 GMT
I was using early KMS but just rebuilt the image comment it out prior. Will report back, thank you.
Comment by John (graysky) - Sunday, 14 February 2016, 20:55 GMT
Same issue :(
Comment by John (graysky) - Friday, 04 March 2016, 19:37 GMT
I still experience this under 4.4.4-1-ARCH but I should add that if I log into gnome, the problem goes away. It is only present under xfce4 which is my favorite DE (I only installed gnome for testing purposes).

Loading...