Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#47922 - [firefox] doesn't allow mutations on indexedDB

Attached to Project: Arch Linux
Opened by Leonidas Spyropoulos (inglor) - Thursday, 28 January 2016, 09:10 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 03 February 2016, 12:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Whenever I try to load the Office 365 Mail page I get an error about mutation. When I use Chromium everything is fine. I tried with Firefox 44 from Ubuntu and I don't have the issue so it's something Archlinux specific.

The main difference between Arch and Ubuntu is I have profile-sync-daemon [0] with Overlay feature on Arch which I disabled and tried again with same results.

The errors is like:
We ran into a problem with the web browser. Please click refresh, then close and reopen your browser and try again.

X-OWA-Error: ClientError;exMsg=A mutation operation was attempted on a database that did not allow mutations.;
X-OWA-Version: undefined
X-FEServer: DB4PR05CA0005
X-BEServer: undefined
Date: 1/28/2016 8:52:48 AM

Additional info:
$ pacman -Qi firefox
Name : firefox
Version : 44.0-1
Description : Standalone web browser from
Architecture : x86_64
Licences : MPL GPL LGPL
Groups : None
Provides : None
Depends On : gtk3 gtk2 mozilla-common libxt startup-notification mime-types
dbus-glib alsa-lib desktop-file-utils hicolor-icon-theme libvpx icu
libevent nss hunspell sqlite ttf-font
Optional Deps : networkmanager: Location detection via available WiFi networks
ffmpeg: H264/AAC/MP3 decoding [installed]
upower: Battery API [installed]
Required By : arch-firefox-search
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 90.69 MiB
Packager : Evangelos Foutras <>
Build Date : Tue 26 Jan 2016 11:16:16 GMT
Install Date : Tue 26 Jan 2016 21:53:17 GMT
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature

Steps to reproduce:
Login to an Office 365 account and load Mail web app.

This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 03 February 2016, 12:46 GMT
Reason for closing:  None
Additional comments about closing:  Not reproducible using a new profile according to OP.
Comment by Evangelos Foutras (foutrelis) - Thursday, 28 January 2016, 10:06 GMT
Have you tried to reproduce the issue with the official Firefox binaries from Mozilla? [1]

If the issue exists there too, it would be best to report the issue to Mozilla's bug tracker. [2]

Comment by Leonidas Spyropoulos (inglor) - Thursday, 28 January 2016, 23:45 GMT
After I created a new profile I can confirm it's not happening. It's something on my firefox profile. I'll have to investigate - thanks.