Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47912 - [emacs] tramp-sh.el deletes /dev/null

Attached to Project: Arch Linux
Opened by Alad Wenter (Alad) - Wednesday, 27 January 2016, 14:58 GMT
Last edited by Jürgen Hötzel (juergen) - Friday, 29 January 2016, 19:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jürgen Hötzel (juergen)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

tramp-sh.el sets HISTFILE=/dev/null, which cause the file to be deleted when /bin/bash is the default /bin/sh (which is the case in Arch). For details, see:

http://debbugs.gnu.org/cgi/bugreport.cgi?bug=19731

Patch which uses HIST{,FILE}SIZE instead, as done in newer versions of tramp-sh.el:

https://ptpb.pw/7gaH

Steps to reproduce:

M-x /root@localhost:<somefile>

Edit until HISTFILESIZE is exceeded, notice /dev/null is replaced by a regular file.
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Friday, 29 January 2016, 19:43 GMT
Reason for closing:  Deferred
Additional comments about closing:  Will be fixed in the upcoming Emacs 25 release
Comment by Jürgen Hötzel (juergen) - Thursday, 28 January 2016, 20:38 GMT
Do you use the tramp version bundled with Emacs?

This seems to be already fixed in recent tramp releases:

https://lists.gnu.org/archive/html/emacs-diffs/2015-02/msg00035.html
Comment by Alad Wenter (Alad) - Thursday, 28 January 2016, 20:58 GMT
Yep, I use the tramp version bundled with emacs 24.5-2.

It's fixed in emacs 25, but I'd say it's an important enough issue to backport it to the Arch package.
Comment by Jürgen Hötzel (juergen) - Friday, 29 January 2016, 19:41 GMT
I prefer not to include single patches for Elisp-packages.

The correct way is to install a recent tramp release using the emacs packages manager.
There are a lot of bugs fixed since the emacs-24.5 release.

I also checked the Fedora-Package. They also don't include this patch.

Loading...