Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47813 - [mono] smuxi-frontend-gnome hangs on exit

Attached to Project: Arch Linux
Opened by Sebastiaan Lokhorst (lonaowna) - Monday, 18 January 2016, 15:21 GMT
Last edited by Isenmann Daniel (ise) - Sunday, 31 January 2016, 12:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I quit Smuxi, the window freezes and nothing happens. My WM (Openbox) then says: "The window "Smuxi" does not seem to be responding.

In the terminal, the following is shown (not sure if related):
(smuxi-frontend-gnome:11585): Gtk-CRITICAL **: gtk_tree_store_get_path: assertion 'iter->user_data != NULL' failed
(smuxi-frontend-gnome:11585): Gtk-CRITICAL **: IA__gtk_tree_model_get_iter: assertion 'path != NULL' failed
(smuxi-frontend-gnome:11585): Gtk-CRITICAL **: IA__gtk_progress_set_percentage: assertion 'percentage >= 0 && percentage <= 1.0' failed
(smuxi-frontend-gnome:11585): Gtk-CRITICAL **: IA__gtk_progress_set_percentage: assertion 'percentage >= 0 && percentage <= 1.0' failed

I already wiped ~/.config/smuxi, but made no difference.

This is 100% reproducible for me.
This task depends upon

Closed by  Isenmann Daniel (ise)
Sunday, 31 January 2016, 12:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  Package version 2 is in the repos and should be on your preferred mirror soon.
Comment by Mirco Bauer (meebey) - Monday, 18 January 2016, 18:46 GMT
What Mono is that on?
Also a debug log would help, quit Smuxi and then start it from a terminal like this: smuxi-frontend-gnome -d

The debug log should be checked for sensitive data, before you paste/post it.
Comment by Sebastiaan Lokhorst (lonaowna) - Tuesday, 19 January 2016, 07:10 GMT
The latest mono from the repositories: mono 4.2.2.10-1
(and by the way, also the latest smuxi: 1.0.1-1)

Log (I pressed the quit button at 08:04:03):
https://gist.github.com/lonaowna/48a3b13e29d01c8637a8

Thanks!
Comment by Mirco Bauer (meebey) - Tuesday, 19 January 2016, 09:47 GMT
thank you for the log but it doesn't reveal the issue yet. Please start it again from a terminal without -d then quit Smuxi and send this signal to the process: kill -QUIT $pid_of_smuxi

That will print a thread dump on the terminal, please paste it here.
Comment by Sebastiaan Lokhorst (lonaowna) - Tuesday, 19 January 2016, 20:33 GMT
Thanks for the suggestion!
However, when I "quit" Smuxi, and then run "kill -QUIT $(pidof mono)", nothing happens. It just remains in the freezed/non-responding state. "kill -KILL $(pidof mono)" works, but that doesn't print a thread dump.
(Smuxi is the only mono process running)
Comment by Mirco Bauer (meebey) - Wednesday, 20 January 2016, 09:34 GMT
The thread dump output appears on the terminal that runs Smuxi, not where kill is executed. It seems to be a deadlock but it does not happen on my Mono 4.2.1
Comment by Sebastiaan Lokhorst (lonaowna) - Wednesday, 20 January 2016, 10:42 GMT
There wasn't a thread dump on any terminal..

It's really weird: after experimenting with some older versions I reinstalled the latest one, and now the problem is gone!
I have no idea what happened.. Maybe a file got corrupted or something..

In any case, thanks a lot for helping me debug!
Comment by Lex Black (TrialnError) - Wednesday, 20 January 2016, 12:29 GMT
I get the same error messages on quit. But smuxi program window doesn't stay.

It stays for me in another situation.
Choosing a remote engine (although running on localhost) makes smuxi unresponsive und needs to be killed the hard way.
A thread dump from this: https://paste.archlinux.de/CHpG/
Should note though, that I use a fresh build from master
Comment by Mirco Bauer (meebey) - Wednesday, 20 January 2016, 17:06 GMT
Please don't hijack this ticket.

The message on quit are unrelated
to the reported issue and they are harmless.
Comment by Lex Black (TrialnError) - Wednesday, 20 January 2016, 18:46 GMT
Just mentioned those messages because they appear in the OP.
And I mainly wrote the message because of the behaving of smuxi, although on a different action was the same (hanging, unresponsive) and wondered if they could be related.

If not sorry for the noise


Comment by Martin Roth (Captain_Rage) - Monday, 25 January 2016, 13:53 GMT
I've had the same issue for quite some time. Reinstalling the packages smuxi, smuxi-server and mono remedied the problem for me. Now Smuxi quits gracefully on exit.
Comment by Mirco Bauer (meebey) - Monday, 25 January 2016, 16:56 GMT
I can reproduce this issue now with Mono 4.2.1 on Debian unstable. It even happens if Smuxi is only in the engine selection dialog and then clicking the "Quit" button.
This issue is tracked upstream here: https://smuxi.im/issues/show/1084
Comment by Mirco Bauer (meebey) - Monday, 25 January 2016, 17:38 GMT
The bug in Mono for this issue is tracked here: https://bugzilla.xamarin.com/show_bug.cgi?id=33020
Comment by Sebastiaan Lokhorst (lonaowna) - Monday, 25 January 2016, 17:42 GMT
Great you've tracked down the cause! After a few runs the problem also reappeared here. Hopefully the Mono folks will be able to fix it soon.
Comment by Mirco Bauer (meebey) - Monday, 25 January 2016, 18:41 GMT
Here is a patch from Mono upstream that maybe fixes this issue: https://github.com/mono/mono/commit/23e34d77f2fd23ab5d61f6ba4aa905817f57668a
Comment by Balló György (City-busz) - Sunday, 31 January 2016, 07:53 GMT
Reassigned to the maintainer of the mono package.
Comment by Mirco Bauer (meebey) - Sunday, 31 January 2016, 11:28 GMT
It was confirmed that the patch fixes this issue, so please apply that patch for the Mono build in ArchLinux.
Comment by Isenmann Daniel (ise) - Sunday, 31 January 2016, 11:53 GMT
I'm on it

Loading...