Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47776 - ImportError: The 'six' package is required; normally this is bundled with this package . . .

Attached to Project: Arch Linux
Opened by Colin Keenan (colinkeenan) - Saturday, 16 January 2016, 06:48 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 16 January 2016, 08:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Traceback (most recent call last):
File "/usr/bin/nvchecker", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 48, in <module>
from pkg_resources.extern import six
File "/usr/lib/python3.5/site-packages/pkg_resources/extern/__init__.py", line 60, in load_module
"distribution.".format(**locals())
ImportError: The 'six' package is required; normally this is bundled with this package so if you get this warning, consult the packager of your distribution.


Additional info:
* python-setuptools 1:19.3-2
I believe this package is to blame because I just did a system upgrade and this was the only relevant package that was upgraded. I run nvchecker after every system upgrade, and nvchecker itself was not upgraded. So, python-setuptools 1:19.3-2 must be the package that's missing the 'six' package that is required.

Steps to reproduce:
I don't know what other packages can generate the error, but I found it while running nvchecker from aur/nvchecker-git.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 16 January 2016, 08:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-setuptools 1:19.3-2
Comment by Doug Newgard (Scimmia) - Saturday, 16 January 2016, 07:04 GMT
python-setuptools 1:19.3-2 requires python-six, so this shouldn't be an issue.
Comment by Colin Keenan (colinkeenan) - Saturday, 16 January 2016, 08:05 GMT
This is weird:

/home/colin %tail /var/log/pacman.log | grep python-setuptools
[2016-01-16 00:26] [ALPM] upgraded python-setuptools (1:19.2-1 -> 1:19.3-1)

In other words, I somehow got version 1:19.3-1 instead of 1:19.3-2. I verified with:

/home/colin %pacman -Qi python-setuptools | grep Version
Version : 1:19.3-1

And, version 1:19.3-1 does not require python-six:

/home/colin %pacman -Qi python-setuptools | grep Depends
Depends On : python-packaging

However, pacman -Syu reports that there is nothing to do.

Even trying to get it directly fails:

/home/colin %sudo pacman -S python-setuptools
warning: python-setuptools-1:19.3-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) python-setuptools-1:19.3-1

Total Installed Size: 1.31 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]


It just wants to re-install version 1:19.3-1.

sudo pacman -Syy doesn't help either. I finally edited /etc/pacman.d/mirrorlist and uncommented the first two U.S. mirrors, did another pacman -Syy, and now there are suddenly 6 more packages getting updated, including this one, which does depend on python-six now:

/home/colin %pacman -Qi python-setuptools | grep Depends
Depends On : python-packaging python-six

The error message from nvchecker is gone.

This bug can be closed.

Loading...