Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47759 - [xorg-xrdb] 1.1.0-2 truncates some resource values in .Xresources.

Attached to Project: Arch Linux
Opened by Aravind Gottipati (aravind) - Friday, 15 January 2016, 02:27 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 01 April 2016, 15:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I noticed this with my recent upgrade to 1.1.0.2. At least one of the resources in my .Xresources file is truncated in an odd location. I almost want to say that this is an upstream application bug, but I tried the old (1.1.0.1) package and it didn't have this problem. Here is how it manifests.


aravind@obelix ~ $ grep url-select .Xresources
URxvt.perl-ext: default,selection,url-select,searchable-scrollback<Control-Mod4-s>
URxvt.keysym.Mod4-u: perl:url-select:select_next
URxvt.url-select.launcher: /home/aravind/linux/bin/browser
URxvt.url-select.underline: false
aravind@obelix ~ $
aravind@obelix ~ $ xrdb -merge .Xresources
aravind@obelix ~
aravind@obelix ~ $ xrdb -query | grep url-select
URxvt.keysym.Mod4-u: perl:url-select:select_next
URxvt.perl-ext: default,selection,url-select,searchable-scrollback<Control-Mod4-s>
URxvt.url-select.launcher: /home/aravind/1/bin/browser
URxvt.url-select.underline: false
aravind@obelix ~ $

If you notice the value for url-select.launcer, the path /home/aravind/linux/bin/browser is now truncated to /home/aravind/l/bin/browser

I know the only things changed are the compile dependencies, so I am not sure where this report belongs.

Happy to provide any debug logs etc you might need.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 01 April 2016, 15:28 GMT
Reason for closing:  Not a bug
Comment by Andreas Radke (AndyRTR) - Saturday, 16 January 2016, 18:34 GMT
The only change is that now gcc is preferred preprocessor when it's installed. It's the more widely used one. In the past mcpp was used.

Check if it also happens when you remove gcc and use mcpp and the other way round. That's the old behavior. You will probably have some weird path location
somewhere that is looked for. Check your urxvt settings file.
Comment by Aravind Gottipati (aravind) - Monday, 18 January 2016, 15:49 GMT
Yup, I realize that the source didn't change and there was some dependency change with gcc/mcpp. I removed gcc from my system after the package 1.1.0-2 was installed and things work correctly. I then installed gcc and removed mcpp and stuff is broken. It appears that this change from using mcpp to gcc is what broke things. AFAICT my path looks normal. Both gcc and mcpp are located in the same /usr/bin directory. I don't set any urxvt properties other than those in the .Xresources file, but regardless of what I se there, xrdb processing should be independent of that?
Comment by Andreas Radke (AndyRTR) - Tuesday, 19 January 2016, 20:22 GMT
Check  FS#46934 !

You will probably have some preprocessor #include stuff somewhere pulling in your broken path. Just fix it.
Comment by Andreas Radke (AndyRTR) - Friday, 01 April 2016, 15:28 GMT
You can modify your xinitrc or wherever your system calls xrdb adding --cpp /usr/bin/mcpp.

Loading...