Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47710 - [linux] Unsetting CONFIG_ACPI_REV_OVERRIDE_POSSIBLE

Attached to Project: Arch Linux
Opened by Niccolò Belli (darkbasic) - Monday, 11 January 2016, 13:11 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 14 April 2016, 16:05 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

CONFIG_ACPI_REV_OVERRIDE_POSSIBLE: Allow supported ACPI revision to be overriden

The platform firmware on some systems expects Linux to return "5" as the supported ACPI revision which makes it expose system configuration information in a special way.

For example, based on what ACPI exports as the supported revision, Dell XPS 13 (2015) configures its audio device to either work in HDA mode or in I2S mode, where the former is supposed to be used on Linux until the latter is fully supported (in the kernel as well as in user space).

This option enables a DMI-based quirk for the above Dell machine (so that HDA audio is exposed by the platform firmware to the kernel) and makes it possible to force the kernel to return "5" as the supported ACPI revision via the "acpi_rev_override" command line switch.

***

Since version 4.4 Linux has working I2S audio for the XPS 13 2015, so we can finally unset this ugly workaround with kernel versions >= 4.4. Fedora Rawhide already disabled it.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 14 April 2016, 16:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.4-1
Comment by Joss Wright (tealeaf) - Thursday, 14 April 2016, 15:00 GMT
  • Field changed: Percent Complete (100% → 0%)
This workaround is still apparently required for the Dell XPS 9340 and 9343, and has been broken now for some months. (I'm posting because the 4.5.1 kernel has just hit stable, and I can't upgrade without building my own kernel with this option enabled.)

Could this be reverted until there's a confirmed working version for all models of the Dell XPS 2015?
Comment by Joss Wright (tealeaf) - Thursday, 14 April 2016, 15:03 GMT
It seems that I may be mistaken in my reopening request. I was under the impression that this was still an issue in 4.5.1. It looks like I (and lots of other people) were conflating this with the apparently new issue in kernel 4.5 that the Dell XPS 2015 needs CONFIG_DW_DMAC_CORE statically compiled for sound to work.

So this should probably be closed again. Sorry about that.

Loading...