Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47691 - [sonnet] running kate in terminal complaints about Sonnet

Attached to Project: Arch Linux
Opened by rezad (rezad) - Sunday, 10 January 2016, 11:28 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 10 January 2016, 15:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


Additional info:
* package version(s)
sonnet-5.17.0-2
* config and/or log files etc.


Steps to reproduce:

run kate from terminal.
see this :

Sonnet: Unable to load plugin "/usr/lib/qt/plugins/kf5/sonnet/voikko.so" Error: "Cannot load library /usr/lib/qt/plugins/kf5/sonnet/voikko.so: (libvoikko.so.1: cannot open shared object file: No such file or directory)"
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 10 January 2016, 15:29 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Sunday, 10 January 2016, 12:02 GMT
This is just a harmless debug message, what's the issue?
Comment by rezad (rezad) - Sunday, 10 January 2016, 15:17 GMT
Sonnet: Unable to load plugin "/usr/lib/qt/plugins/kf5/sonnet/voikko.so" Error: "Cannot load library /usr/lib/qt/plugins/kf5/sonnet/voikko.so: (libvoikko.so.1: cannot open shared object file: No such file or directory)"

this is just a debug massage.?
it says sonnet couldn't load a language specific library (Finnish).
why would sonnet even looking for this?
Comment by Antonio Rojas (arojas) - Sunday, 10 January 2016, 15:28 GMT
sonnet tries to load all plugins, and it will inform you if some can't be loaded because you don't have the needed optional dependencies installed. Nothing is broken here.

Loading...