Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47663 - [lib32-pam] 1.2.1-1 links to old lib32-libtirpc library

Attached to Project: Community Packages
Opened by Nicholas Hogg (made_in_nz) - Thursday, 07 January 2016, 20:55 GMT
Last edited by Maxime Gauduin (Alucryd) - Friday, 08 January 2016, 07:31 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

[lib32-pam] 1.2.1-1 links to old lib32-libtirpc library. Not compatible with latest lib32-libtirpc 1.0.1-1 package.

I am getting the following in my logs:
PAM unable to dlopen(/usr/lib32/security/pam_unix.so): libtirpc.so.1: cannot open shared object file: No such file or directory
PAM adding faulty module: /usr/lib32/security/pam_unix.so

Checked linked libraries of /usr/lib32/security/pam_unix.so and it appears to be linking to an old version of libtirpc:

[root]# ldd /usr/lib32/security/pam_unix.so
linux-gate.so.1 (0xf7728000)
libpam.so.0 => /usr/lib32/libpam.so.0 (0xf76c3000)
libdl.so.2 => /usr/lib32/libdl.so.2 (0xf76be000)
libcrypt.so.1 => /usr/lib32/libcrypt.so.1 (0xf768c000)
libnsl.so.1 => /usr/lib32/libnsl.so.1 (0xf7671000)
libtirpc.so.1 => not found
libc.so.6 => /usr/lib32/libc.so.6 (0xf74b6000)
/usr/lib/ld-linux.so.2 (0x565b3000)

I have lib32-libtirpc 1.0.1-1 installed, which installs /usr/lib32/libtirpc.so.3

This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Friday, 08 January 2016, 07:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.2.1-1

Loading...