FS#47616 - [tk] File /usr/include/tkFont.h seems to be missing

Attached to Project: Arch Linux
Opened by Benamin Braun (taifunbrowser) - Monday, 04 January 2016, 16:19 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 17 September 2017, 20:26 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



File /usr/include/tkFont.h appears to be missing.

Building Togl (version 2.0, http://togl.sourceforge.net/) fails without this file. Togl2.0 is required to run AutoDockTools.

I downloaded the file from http://www.opensource.apple.com/source/tcl/tcl-20/tk/tk/generic/tkFont.h?txt and manually installed it, and then everything worked.

Additional info:

Steps to reproduce:
Try to build Togl2.0, it will fail on missing file
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 17 September 2017, 20:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  tk 8.6.7-2
Comment by Doug Newgard (Scimmia) - Monday, 04 January 2016, 16:51 GMT
Related:  FS#14388 
Comment by Colin Heinzmann (DepthDeluxe) - Wednesday, 06 January 2016, 18:55 GMT
Downloaded and built tk from upstream and it doesn't appear to install tkFont.h into /usr/include. My guess is that this is some sort of internal header file. The directions for building togl (http://togl.sourceforge.net/download.html) note that you should have the source for both tcl and tk in order to build Togl from source.

I tried downloading Togl2 from the upstream repo and configure it, and I'm getting this strange error:

[colin Togl2.0]$ ./configure --with-tcl=/usr/lib/ --with-tk=/usr/lib/ --with-x
checking for Tcl private include files... configure: error: Cannot find private header tclInt.h in /usr/include
[colin Togl2.0]$ ls /usr/include/tclInt.h
[colin Togl2.0]$

The configuration script thinks that tclInt.h doesn't exist although it definitely does. It appears that togl 2.0 was released in about 2008, making it pretty old. You may also either be running into differences in tcl/tk since Togl was last updated, or an error in the configuration script
Comment by Benamin Braun (taifunbrowser) - Wednesday, 06 January 2016, 18:59 GMT
Ah, I remember I got that problem too. I fixed it by opening the "configure" file and s!/generic!!g, since that configure script assumes that you have installed the headers under <somedir>/generic/* whereas the PKGBUILD here is just installing them into /usr/include directly..
Comment by Eli Schwartz (eschwartz) - Sunday, 17 September 2017, 18:33 GMT
This seems to have been deliberately removed in tk 8.6.0-1, is it something that should be brought back or something that software like togl should not be doing?
Comment by Antonio Rojas (arojas) - Sunday, 17 September 2017, 20:24 GMT
Fedora, Debian and Gentoo all install them, so I see no reason not to do the same ourselves