Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47573 - [qt5-webengine] pyqt5 webengine widgets crashes after latest update

Attached to Project: Arch Linux
Opened by kachelaqa (kachelaqa) - Thursday, 31 December 2015, 00:30 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 16 February 2017, 18:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After the updates on 30th Dec 2015, pyqt5 programs that use webengine immediately crash after loading a webpage. It seems that the update of the nss package is the culprit, since downgrading it to version 3.20.1-1 fixes the problem.

Additional info:

python-pyqt5-5.5.1-2
qt5-webengine-5.5.1-7
nss-3.21-1

Steps to reproduce:

Python 3.5.1 (default, Dec 7 2015, 12:58:09)
[GCC 5.2.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import sys
>>> from PyQt5 import QtCore, QtWidgets, QtWebEngineWidgets
>>> app = QtWidgets.QApplication(sys.argv)
>>> w = QtWebEngineWidgets.QWebEnginePage()
>>> w.load(QtCore.QUrl('https://www.archlinux.org/'))

Warning: Program '/usr/bin/python3' crashed.


This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 16 February 2017, 18:31 GMT
Reason for closing:  Fixed
Comment by Kovid Goyal (kovidgoyal) - Monday, 04 January 2016, 05:27 GMT
Simpler reproduction:
python -c "from PyQt5.Qt import *; app = QApplication([]); w = QWebEngineView(); w.load(QUrl('https://google.com')); w.show(); app.exec_()"

And note that this likely affects all QtWebEngine using apps, not just python based ones. Downgrading nss does indeed fix it.
Comment by Anke Boersma (abveritas) - Wednesday, 06 January 2016, 01:56 GMT
Nss 3.21 dropped some long planned legacy support which Chromium versions below 45 still uses. Qtwebengine 5.5.1 uses a a much older Chromium checkout, Qtwebengine 5.6 beta is still having this issue, snapshot is based on Chromium 43. Expect this to be fixed with Qtwebengine 5.6 RC, commit is up to pull from 45:
https://github.com/qtproject/qtwebengine/blob/5.6/tools/scripts/version_resolver.py#L54
Comment by Florian Bruhin (The-Compiler) - Monday, 08 February 2016, 08:39 GMT
The commit updating to Chromium 45 was in the 5.6 beta, and a Qt developer just confirmed 5.6 was on 45 since August or so - so I think you're wrong about the beta being based on Chromium 43. :)
Comment by Martin Raivio (MurdRav) - Tuesday, 15 March 2016, 23:59 GMT
Weird thing is cpp QWebEngineView apps do not crash .
Comment by Florian Bruhin (The-Compiler) - Wednesday, 16 March 2016, 05:16 GMT
@MurdRav - and you're sure they're built against Qt 5.5 from [extra], not some Qt 5.6 build?
Comment by Martin Raivio (MurdRav) - Wednesday, 16 March 2016, 19:46 GMT
To Florian. Yes. I have nss 3.22.1-1
python-pyqt5 5.5.1-2
qt5-webengine 5.5.1-10
and got qt5-examples 5.5.1-1 from AUR
I did as root in /usr/share/doc/qt/examples/webenginewidgets/browser qmake-qt5 browser.pro
and then make , and then <dot><slash>browser https:www.google.com and here I am .
Sorry can not type dot slash as for some stupid reason it is bound to 'find'.
Wheras pyqt webengine crashes on google immediately.
Comment by Martin Raivio (MurdRav) - Wednesday, 16 March 2016, 19:50 GMT
Urps I meant https:<slash><slash>www.google.com Just can not type a slash in this thing.
Comment by Florian Bruhin (The-Compiler) - Friday, 08 April 2016, 04:17 GMT
This was fixed by Qt 5.6.

Loading...