Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47542 - poppler-data should be a proper dependency of poppler.

Attached to Project: Arch Linux
Opened by crocket (crocket) - Sunday, 27 December 2015, 08:08 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 27 December 2015, 14:49 GMT
Task Type Support Request
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: A while ago, I installed okular and tried to view a PDF file in
korean. I could not see any korean letter in okular. I installed
evince, but evince couldn't display korean letters, either. But,
google chrome could display korean letters in PDF. I didn't know what
was going on.

After about half an hour of googling and thinking, a package called
poppler-data somehow caught my eyes, so I installed it. Then, I could
read korean PDF files.

It turned out that poppler-data was an optional dependency of poppler.
Since I installed okular with a command "pacman -Syu
kdegraphics-okular", hundreds of packages buried the output of okular
installation, and I couldn't have thought an optional package was
going to cause a font problem.

After careful inspection, I found that poppler-data was an optional
dependency of poppler with a description saying "encoding data to
display PDF documents containing CJK characters".

I have used various linux distributions for 7 years, and if it took
half an hour for me, it could take a few hours for relatively
inexperienced people. There are billions of asians whose languages are
CJK, and millions of foreigners may read and write CJK regularly or
occasionally. CJK support should not be optional in softwares including okular and evince.
I propose that poppler-data should become a proper dependency of poppler.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 27 December 2015, 14:49 GMT
Reason for closing:  Not a bug

Loading...