Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47506 - [vlc] Segfault (wrong dependencys)

Attached to Project: Arch Linux
Opened by Ruben Kelevra (RubenKelevra) - Wednesday, 23 December 2015, 20:21 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 03 June 2016, 12:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
on a fresh installed system, the vlc package does not install all needed dependencys for itself, some of the build-dependencys are missing. The following package is missing as normal dependency:

'projectm'

Additional info:
* package version(s)
2.2.1-11
* config and/or log files etc.
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[00000000023e3158] core libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.


Steps to reproduce:
* Install
* Run
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 03 June 2016, 12:56 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Wednesday, 23 December 2015, 20:53 GMT
vlc works fine for me, projectm is not installed.
Comment by Ruben Kelevra (RubenKelevra) - Thursday, 24 December 2015, 13:36 GMT
For me not. If I remove projectm it's segfaulting, if I add it, it's working. I tested it several times.

On my laptop it's working without projectm.


This is my Laptop:


processor 0-3:

vendor_id : GenuineIntel
cpu family : 6
model : 58
model name : Intel(R) Core(TM) i5-3337U CPU @ 1.80GHz
stepping : 9
microcode : 0x17
cpu MHz : 1325.671
cache size : 3072 KB
physical id : 0
siblings : 4
core id : 1
cpu cores : 2
apicid : 3
initial apicid : 3
fpu : yes
fpu_exception : yes
cpuid level : 13
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt
bugs :
bogomips : 3591.53
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:


This is the maschine which has issues running vlc without projectm:

processor 0-3:

vendor_id : GenuineIntel
cpu family : 6
model : 55
model name : Intel(R) Celeron(R) CPU J1900 @ 1.99GHz
stepping : 8
microcode : 0x815
cpu MHz : 1651.448
cache size : 1024 KB
physical id : 0
siblings : 4
core id : 3
cpu cores : 4
apicid : 6
initial apicid : 6
fpu : yes
fpu_exception : yes
cpuid level : 11
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer rdrand lahf_lm 3dnowprefetch ida arat epb dtherm tpr_shadow vnmi flexpriority ept vpid tsc_adjust smep erms
bugs :
bogomips : 3995.00
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

Might be somehow related to the silvermont atom cpu core?
Comment by Doug Newgard (Scimmia) - Thursday, 24 December 2015, 15:16 GMT
More likely a configuration issue. projectm is listed as an optional dep "for ProjectM visualisation plugin". Do you have that enabled?
Comment by Doug Newgard (Scimmia) - Monday, 28 December 2015, 14:42 GMT
Ping?
Comment by Ruben Kelevra (RubenKelevra) - Tuesday, 05 January 2016, 09:19 GMT
  • Field changed: Percent Complete (100% → 0%)
This issue is not solved.
Comment by Doug Newgard (Scimmia) - Tuesday, 05 January 2016, 09:19 GMT
OK, so do you have that plugin enabled?
Comment by Ruben Kelevra (RubenKelevra) - Thursday, 07 January 2016, 08:33 GMT
I'm sorry for the late response, I was on holiday.

No changes on the config at all. I just installed and started vlc on this computer.

Comment by Doug Newgard (Scimmia) - Thursday, 07 January 2016, 15:46 GMT
and if you delete/rename ~/.config/vlc?
Comment by Nick Rossenbach (JackTemaki) - Saturday, 09 January 2016, 11:22 GMT
i can confirm the error:

I got segmentation fault after updating to the latest version.
Installing projectm fixed the problem.

And i think its not related to the atom processor, i use an i7

I didn't install the plugin either
Comment by Doug Newgard (Scimmia) - Saturday, 09 January 2016, 15:46 GMT
"I didn't install the plugin either"

Yes, you most certainly did. It's part of the vlc package. Same question, does this still happen with a totally clean config?
Comment by Nick Rossenbach (JackTemaki) - Sunday, 10 January 2016, 18:43 GMT
im sorry i didnt know.

if i delete ~/.config/vlc i still get the error
Comment by Ruben Kelevra (RubenKelevra) - Monday, 11 January 2016, 06:28 GMT
Happens with clean config as well on this maschine, might be related to a change of the default-config - since on my notebook without a clean config it's working.
Comment by freswa (frederik) - Sunday, 28 February 2016, 22:32 GMT
Same problem here, installing projectm fixes this. Also tried deleting config folder, does not affect the problem on my machines.
Comment by ldng (ldng) - Wednesday, 02 March 2016, 20:52 GMT
$ vlc
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[00000000011b0148] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
Erreur de segmentation (core dumped)

$ vlc --ignore-config
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000000797148] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
Erreur de segmentation (core dumped)

$ vlc --reset-config
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[00000000020a3148] core libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
Erreur de segmentation (core dumped)

Install projectm, it works...
Uninstall projectm, it segfaults...

It's annoying.
Comment by Pavlos Touboulidis (pav) - Thursday, 03 March 2016, 06:17 GMT
Installing projectm allows VLC to launch for me but it crashes trying to play a video:

Failed to open VDPAU backend libvdpau_radeonsi.so: cannot open shared object file: No such file or directory

Installing mesa-vdpau fixes it.
Comment by Maxime Gauduin (Alucryd) - Saturday, 05 March 2016, 09:24 GMT
FWIW, vlc runs fine without projectm here as well. Pro tip, use mpv :P
Jokes aside, I'd still leave projectm as optdep, it _should_ not need it. A warning in the install file is the way to go IMHO.
Comment by Ruben Kelevra (RubenKelevra) - Thursday, 10 March 2016, 10:25 GMT
If vlc segfaults without projectm this doesn't meets the criterion of a optional dependency, regardless what you claim here.

Comment by Tengis Narankhuu (tengisu) - Saturday, 23 April 2016, 15:29 GMT
Installing projectm fixes it for me.
Comment by Ruben Kelevra (RubenKelevra) - Saturday, 23 April 2016, 21:14 GMT
Since we got five confirmations here build it without the dependency or ship it with it, there's no other way to go. Else we waiting here for more than a quarter for a fix, you're wasting the time of the user. If you think it's an upstream bug or a documentation error, feel free to file it.
Comment by Doug Newgard (Scimmia) - Saturday, 23 April 2016, 22:03 GMT
The problem is that there are many others, me included, that run it just fine without projectm.
Comment by Ruben Kelevra (RubenKelevra) - Sunday, 24 April 2016, 10:25 GMT
That really doesn't matter since on some (hardware?) configurations vlc crash if it's not installed, so this isn't a optional dependency because on some configurations it might not crash. It should never crash if 'vlc' is installed.
Comment by Doug Newgard (Scimmia) - Sunday, 24 April 2016, 14:23 GMT
Of course it matters. Figure out why it's crashing for you and we can actually do something.
Comment by Julio (The_Loko) - Monday, 23 May 2016, 19:28 GMT
Had this issue until I upgraded to vlc 2.2.3-3, now it seems to work without projectm. Can anyone confirm?
Comment by Pavlos Touboulidis (pav) - Tuesday, 24 May 2016, 07:08 GMT
I tried removing projectm and it still works fine.
Comment by Tengis Narankhuu (tengisu) - Tuesday, 24 May 2016, 11:00 GMT
VLC works fine without projectm.

Loading...