Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47428 - [wpa_supplicant] 1:2.5-1 fails with Intel Wireless 3165

Attached to Project: Arch Linux
Opened by Gerry Kessler (renegat) - Friday, 18 December 2015, 01:58 GMT
Last edited by Evangelos Foutras (foutrelis) - Sunday, 27 December 2015, 13:38 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
wpa_supplicant 1:2.5-1 fails with Intel Wireless 3165 (M2), claims 'No such device'.


Additional info:
Using wpa_supplicant 1:2.5-1:

# wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
Could not read interface p2p-dev-wlp2s0 flags: No such device

Intel Wireless 7260 miniPCI-e not affected.
Centrino Advanced-N 6230 miniPCI-e not affected.

Steps to reproduce:
Update to latest wpa_supplicant: Wireless not working!
Downgrade to wpa_supplicant (1:2.3-1): Wireless works again.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Sunday, 27 December 2015, 13:38 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#44731 
Comment by Doug Newgard (Scimmia) - Friday, 18 December 2015, 05:48 GMT
What is your interface name?
Comment by Evangelos Foutras (foutrelis) - Thursday, 24 December 2015, 18:58 GMT
Following upstream's request for a detailed log, please replace -B with -d and provide the output log. [1]

I have reopened this report instead of posting in  FS#44731  because this one doesn't appear to use netctl and thus is better for debugging.

[1] http://lists.infradead.org/pipermail/hostap/2015-December/034392.html
Comment by Evangelos Foutras (foutrelis) - Sunday, 27 December 2015, 13:38 GMT
Closing again as I believe the main issue has been resolved and the "Could not read interface p2p-dev-wlp2s0 flags: No such device" message is harmless according to upstream.

Loading...