Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47423 - libxcursor unlisted dependency on Adwaita theme

Attached to Project: Arch Linux
Opened by Alex Suykov (axs) - Thursday, 17 December 2015, 14:35 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 17 December 2015, 17:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

libxcursor is built with (custom, non-upstream) index.theme referencing Adwaita, but adwaita-icon-theme is not listed in package dependencies.

This should probably be a per-user setting anyway, so proposed solution is to drop custom index.theme.
Alternatively, adwaita-icon-theme should be added to libxcursor dependencies.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 17 December 2015, 17:04 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Covered by optional dep
Comment by Doug Newgard (Scimmia) - Thursday, 17 December 2015, 16:03 GMT
index.theme is there for a reason.  FS#38032 

Are you certain the gnome-themes-standard optdep isn't enough?
Comment by Alex Suykov (axs) - Thursday, 17 December 2015, 17:01 GMT
Oh wow. If that's something gnome-shell needs, shouldn't index.theme belong to gnome-themes-standard?
There is gnome-shell <- gnome-themes-standard dependency already.

Optdep is not enough in that it allows installing index.theme without the files referenced there.
That's exactly the situation I have, libxcursor but no gnome-* and no gtk3-*, thus no Adwaita.

That dangling reference does not seem to break anything however, so if that's the only way to fix Gnome then call it not a bug I guess.

Loading...