Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47414 - [geeqie] due to C++ ABI changes, geeqie doesn't open RAW files any more

Attached to Project: Arch Linux
Opened by Michael Hellwig (the_eye) - Wednesday, 16 December 2015, 22:20 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 27 June 2017, 08:14 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Evangelos Foutras (foutrelis)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
geeqie was able to (extremely quickly) display a directory of raw files by showing the jpeg previews that are enclosed in the RAW files. This capability was broken by the C++ ABI change. I myself do not even understand what that means, but that's what it says on the related debian bug and the patch they applied fixed the problem for me ..

Additional info:
* package version(s) - 1.2.2-3
* config and/or log files etc.


Steps to reproduce:
open geeqie
navigate to a folder with RAW pictures
click on one
a "broken image file" symbol is displayed.

how to fix:
apply the patch from http://sources.debian.net/src/geeqie/1:1.2.2-2/debian/patches/geeqie-bug-800350-libstc%2B%2B-copy-on-write-string.diff/
and recompile
then the same file is displayed again. Hooray.

Please also apply this patch.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 27 June 2017, 08:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  geeqie 1.3-2 (though it might have already been partly/mostly working in 1.3-1)
Comment by Doug Newgard (Scimmia) - Wednesday, 16 December 2015, 22:27 GMT
Has anyone sent this patch upstream?
Comment by Michael Hellwig (the_eye) - Wednesday, 16 December 2015, 22:31 GMT
the project lives on sourceforge, the last update was in 2012, they had a git on gitorious ..
I sortof presume it's dead?

which sucks because IMO no real replacement exists.
Comment by Ariel Rosenfeld (lord_rel) - Sunday, 20 December 2015, 13:20 GMT
they moved development to their own website http://www.geeqie.org , you can see recent developments at http://www.geeqie.org/cgi-bin/gitweb.cgi?p=geeqie.git its worth trying to use the sourceforge ticket system to try and upstream the patch

Loading...