Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47411 - [steam] Steam Controller not working on 1.0.0.51-1

Attached to Project: Community Packages
Opened by Jesus Gonzalez (txus) - Wednesday, 16 December 2015, 17:05 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 16 December 2015, 18:12 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

With steam package version 1.0.0.51-1, the steam controller is no longer working for me. There seems to be a permission problem originated from the use of the "uaccess" TAG, since using custom rules with MODE and GROUP instead works just fine.




Additional info:

steam: 1.0.0.51-1
sddm: 0.13.0-2
systemd: 228-3

- Using SDDM and Xfce, no custom stuff, not even a config for sddm
- loginctl shows my session in seat0
- Default udev rules in package, not working:

SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0660", TAG+="uaccess"
KERNEL=="uinput", SUBSYSTEM=="misc", OPTIONS+="static_node=uinput", TAG+="uaccess"

- Custom udev rules, working (me being in the steam group)

SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0660", GROUP="steam"
KERNEL=="uinput", SUBSYSTEM=="misc", MODE="0660", GROUP="steam", OPTIONS+="static_node=uinput"


Steps to reproduce:

- Launch Steam
- Plug in Steam Controller
- Try to do anything with it
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 16 December 2015, 18:12 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#47330 

Loading...