Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47392 - [libtorrent-rasterbar] 1.0.7-2: deluge dl speed stuck between 0.5-2.0KiB/s

Attached to Project: Arch Linux
Opened by geosmin (geosmin) - Tuesday, 15 December 2015, 20:42 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 09 May 2017, 02:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

At 2015-12-10 03:08 libtorrent-rasterbar from upgraded 1:1.0.7-1 -> 1:1.0.7-2 through a pacman -Syu

At 2015-12-10 13:03:44 I added a new torrent to deluged and noticed it would only download at 0.5-2.0KiB/s, I assumed it was an issue with the tracker.

I've since noticed this is happening with all torrents and trackers. Nothing in my configs or setup has changed and I even tried starting deluged with a clean config to no avail. Same issue. Problem does not occur on clients not based on libtorrent-rasterbar. Tried manually downgrading libtorrent-rasterbar to 1:1.0.7-1 but that causes deluged to crash after about a minute.

Nothing out of the ordinary in deluged log.


Steps to reproduce:

1. Install deluge
2. Add torrent
3. Observe download speed
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 09 May 2017, 02:40 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Wednesday, 16 December 2015, 07:39 GMT
Anything in the logs? Any errors when run from a command line? Entire system up to date and all AUR/foreign packages rebuilt?
Comment by geosmin (geosmin) - Wednesday, 16 December 2015, 18:00 GMT
Logs are clean, no errors. System (including AUR) is up to date.
Comment by Doug Newgard (Scimmia) - Wednesday, 16 December 2015, 18:45 GMT
Since heftig (deluge maintainer) won't take it, how about Allan? Seems to be related to the C++ ABI change.
Comment by Allan McRae (Allan) - Thursday, 17 December 2015, 00:32 GMT
I can download at full speed in deluge.
Comment by Nik S (Niksko) - Monday, 30 May 2016, 04:51 GMT
I'm also experiencing this issue. A workaround seems to be to reinstall the package from pacman. However it seems like the bug periodically crops up again, because I did this last week to fix the issue and I just had to do it again.

For me the speed was more like 50ish kbps. This is suspiciously close to the speed that I have set in deluge's scheduler plugin for particular times of the day, but this could just be a coincidence.
Comment by jason begley (jayray) - Tuesday, 20 September 2016, 02:39 GMT
Garbage... now boost-libs are preventing load. Guess what the easy fix is? Rebuild deluge-1.3.13-1 after upgrading libtorrent-rasterbar and boost-libs. Tested 100%. So maybe we need a deluge-1.3.13-2?? BTW the downgrade to boost-libs 1.60 borks libvirtd hence my effort to find fix...
Comment by John (graysky) - Monday, 24 April 2017, 19:13 GMT
Bug still relevant?
Comment by jason begley (jayray) - Monday, 08 May 2017, 07:31 GMT
No issues on my end.. Contact original opener to make sure it's not still an issue.

Loading...