Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47336 - [kruler] Add dependency on libxkbcommon-x11

Attached to Project: Arch Linux
Opened by Jonathan Schuster (jschuster) - Friday, 11 December 2015, 16:24 GMT
Last edited by Antonio Rojas (arojas) - Monday, 14 December 2015, 10:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

kruler appears to depend on libxkbcommon, but the package doesn't depend on it (even transitively). Using ldd on /usr/lib/qt/plugins/platforms/libqxcb.so as recommended on the Qt wiki page identifies that library as the missing dependency on my system.

I don't fully understand why qt5-base doesn't just pull it in. It seems pretty explicit that it's a dependency of Qt, but I guess maybe they're more like optional dependencies? In either case, kruler clearly depends on it (see repro steps below), so the dependency should probably be added to either kruler or qt5-base.

Steps to reproduce:

1. Install kruler from pacman on a system that does not yet have the libxkbcommon-x11 package installed
2. Try to start kruler, instead get the following error:

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.

This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 14 December 2015, 10:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5 5.5.1-6
Comment by Antonio Rojas (arojas) - Friday, 11 December 2015, 18:10 GMT
Felix: should this be added to qt5-x11extras instead?

Loading...