Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47325 - [truecrypt] 1:7.1a-3: Mount: Invalid characters encountered

Attached to Project: Arch Linux
Opened by midixinga (midixinga) - Thursday, 10 December 2015, 19:22 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 19 May 2016, 22:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 36
Private No

Details

Description:
Truecrypt 1:7.1a-3 doesn't work for me. When I try to mount, I get for all my truecrypt volumes (devices) the error: Invalid characters encountered.
the truecrypt volumes were formatted with ext4fs.

After downgrade to 1:7.1a-2 it's working again
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 19 May 2016, 22:26 GMT
Reason for closing:  Fixed
Additional comments about closing:  truecrypt 1:7.1a-4
Comment by robert (someotherguy) - Friday, 11 December 2015, 07:18 GMT
Can confirm this, seems not to depend on the volumes file system. my VFat volumes displayed the same message.
Comment by bard (bardamatic) - Friday, 11 December 2015, 07:32 GMT
Can confirm as well on ext3 volume

Rolled back to truecrypt-1:7.1a-2-x86_64.pkg.tar.xz from here:
http://ala.seblu.net/packages/t/truecrypt/

And it is working again
Comment by _ (frederik) - Friday, 11 December 2015, 10:47 GMT
Same problem here
Comment by jim945 (jim945) - Friday, 11 December 2015, 11:02 GMT
Same problem. Do not mount the encrypted files
Comment by luc (mitras2) - Friday, 11 December 2015, 11:56 GMT
Same ploblem here. Downgrade is a workaround. Thanks for the Link bard
Comment by Martin Schnitkemper (Martin-MS) - Friday, 11 December 2015, 21:29 GMT
I can confirm, same problem here.
Comment by Georg (georgnix) - Saturday, 12 December 2015, 13:28 GMT
I see this error too.
I get one additional error:

fuse: bad mount point `': No such file or directory
Comment by Andrey (Gendalf) - Saturday, 12 December 2015, 18:23 GMT
I think problem with fuse package. See this lasts comments https://aur.archlinux.org/packages/veracrypt
Comment by Andrey (Gendalf) - Saturday, 12 December 2015, 18:25 GMT
I recompile fuse package but it's not work ((((
Comment by Patrick Eigensatz (pentix) - Sunday, 13 December 2015, 12:02 GMT
Can confirm this for normal volumes as well. Running truecrypt as root does not change anything. Always reproducible.
Comment by Patrick Eigensatz (pentix) - Sunday, 13 December 2015, 12:07 GMT
Can confirm that the problem disappeared after downgrading to 1:7.1a-2.
I might have a look at the code to see what changed...
Comment by midixinga (midixinga) - Sunday, 13 December 2015, 14:18 GMT
I don`t think, that the sourcecode of truecrypt itself changed.
I think, it was only recompiled with the new gcc
So the problem is maybe not as simple
Comment by Jakub Urbanowicz (kuba_66) - Sunday, 13 December 2015, 21:12 GMT
Yep, had a look at the gentoonians forum: http://tiny.pl/gg82h
They offer a good workaround:
sudo cryptsetup open --type tcrypt <container> <name>
sudo mount /dev/mapper/<name> <mountpoint>
anything can be used for <name>
I didn't even have to use the second line: a mount dialog popped up.
Lots of issues to be expected with the gcc transition.
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 13 December 2015, 21:26 GMT Comment by Patrick Eigensatz (pentix) - Tuesday, 15 December 2015, 22:04 GMT
Changes about the ABI are documented here: https://www.archlinux.org/news/c-abi-change/
Comment by Marcus Radisch (amarradi) - Wednesday, 16 December 2015, 19:35 GMT
can confirm that bug. On my vbox with win7 it is mountable...
Comment by Patrick Drechsler (draptik) - Wednesday, 16 December 2015, 20:53 GMT
@kuba_66 thanks for sharing the workaround!
Comment by Patrick Drechsler (draptik) - Friday, 18 December 2015, 07:30 GMT
Comment by Christopher J. Madsen (cjm) - Monday, 04 January 2016, 21:08 GMT
Same problem here with ext4 volume. Downgrading to the truecrypt-1:7.1a-2-x86_64.pkg.tar.xz that was still in /var/cache/pacman/ fixed it.
Comment by Arthur Borsboom (ArthurBorsboom) - Thursday, 14 January 2016, 15:29 GMT
Is the package fixable, for example by recompiling?
Comment by midixinga (midixinga) - Wednesday, 20 January 2016, 22:30 GMT
as far as I can estimate, there are three possibilities:

- go back to version truecrypt-1:7.1a-2
- remove truecrypt from extra-repo and downgrade it to AUR
- someone knows "how to fix" and "what to fix"

the situation now with a broken unusable package is the worst situation imho
Comment by Arthur Borsboom (ArthurBorsboom) - Thursday, 21 January 2016, 08:09 GMT
I have switched to veracrypt.

Although not audited, it is maintained and has truecrypt support.
Comment by Martin Schnitkemper (Martin-MS) - Thursday, 21 January 2016, 20:17 GMT
Veracrypt has the same issues: https://veracrypt.codeplex.com/workitem/173 only pre-compiled binaries are available at the moment.
I agree with midixinga that the project should be dropped to the AUR until the problem has been fixed, it makes no sense to keep an unstable application in a stable branch of the distribution.
Comment by Patrick Eigensatz (pentix) - Thursday, 21 January 2016, 20:27 GMT
Isn't it possible to modify PKGBUILD files, etc. in the ArchBuildSystem to achieve it gets compiled with the old ABI again?
Comment by Martin Sand (sandstorm) - Thursday, 21 January 2016, 21:27 GMT
I agree with midixinga and Martin Schnitkemper, I would ask for downgrading if the problem persist. I expect stable packages in the official repositories.

I checked the whole comment tree here but could not find an answer. Is there an Truecrypt AUR package which can be compiled and does not contain the error?
Comment by Arthur Borsboom (ArthurBorsboom) - Friday, 22 January 2016, 07:49 GMT
Veracrypt has been rebuild against the working ABI and thus this issue does not exist with Veracrypt (in Arch).
Comment by Steven Roose (stevenroose) - Thursday, 04 February 2016, 02:35 GMT
For me, it worked when I downloaded Veracrypt and checked the "Truecrypt mode" checkbox.
Comment by challisto (challisto) - Thursday, 03 March 2016, 00:33 GMT
Comment by midixinga (midixinga) - Thursday, 03 March 2016, 07:00 GMT
I got an email with the content:
----------
Upgraded to Kernel: x86_64 Linux 4.4.1-2-ARCH and the problem went away.
----------

I can't confirm, problem still persists
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 06 March 2016, 09:42 GMT
Same here: got also that comment, I am on kernel 4.4.3-1, tried it again, meanwhile I didn't got any error message, the process just hangs. I am rather surprised that the application still be kept in the stable repo since the project is dead from upstream and no longer able to build it from source against a current system.
Comment by Levente Polyak (anthraxx) - Thursday, 19 May 2016, 15:34 GMT
Please test version 1:7.1a-4 from [testing] repository, it should resolve this issue. please also give some feedback if it does.
Comment by Patrick Eigensatz (pentix) - Thursday, 19 May 2016, 19:22 GMT
I just tested 1:7.1a-4 from [testing]. It did work flawlessly. I suggest moving 7.1a-4 to [extra]. Thank you!
Comment by Martin Schnitkemper (Martin-MS) - Thursday, 19 May 2016, 19:26 GMT
I can also confirm that 1:7.1a-4 works for me, too. Thank you to take care about the problem.
Comment by midixinga (midixinga) - Thursday, 19 May 2016, 20:50 GMT
for me the issue is solved with version 1:7.1a-4
thanks a lot

Loading...