Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47320 - [wpa_supplicant] 1:2.5-1 breaks WPA2 Enterprise PEAP MSCHAPv2 connection

Attached to Project: Arch Linux
Opened by alleut (alleut) - Thursday, 10 December 2015, 12:54 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 11 December 2015, 16:01 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After the update from 2.3 to 2.5 NetworkManager keeps asking for password in WPA2 Ent PEAP MSCHAPv2 connection. Downgrade to 2.3 fixed that and connection is established immediately with exactly the same settings of NetworkManager.

Additional info:
* package version(s)
local/libnm-glib 1.0.8-1
local/networkmanager 1.0.8-1
local/networkmanager-dispatcher-ntpd 1.0-6
local/networkmanager-openvpn 1.0.8-1
local/networkmanager-pptp 1.0.8-1
local/networkmanager-vpnc 1.0.8-1
local/nm-connection-editor 1.0.8-1
local/ppp 2.4.7-2
local/pptpclient 1.8.0-2
* config and/or log files etc.


Steps to reproduce:
1. Upgrade to [wpa_supplicant] 1:2.5-1
2. Try to connect to a WPA2 PEAP MSCHAPv2 network (e.g. Eduroam).
3. Connection fails, NetworkManager Keeps asking for password.
4. Downgrade to [wpa_supplicant] 1:2.3-1
5. Now connection works again.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 11 December 2015, 16:01 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#47311 
Comment by Christian Hesse (eworm) - Thursday, 10 December 2015, 13:16 GMT
I am connected to an eduroam network right now with WPA2 PEAP MSCHAPv2. Works perfectly here.

Did you try to restart wpa_supplicant.service? Can you provide any logs? Be more specific about configuration? (Make sure not to share you passwords!)

libnm-glib 1.0.8-1
networkmanager 1.0.8-1
wpa_supplicant 1:2.5-1
Comment by alleut (alleut) - Thursday, 10 December 2015, 21:25 GMT
What logs are best to provide? Could you tell me pls how do I make wpa_supplicant log to a file when it is evoked by NetworkManager?

I have tried both to restart and reenable wpa_supplicant and NetworkManager services.

I do not config wpa_supplicant directly, I use NetworkManager Gnome3 applet for that, and it does fine with 2.3. The config in the applet:
WPA2 Enterprise.
PEAP.
Anon id: <empty>.
CA cert: "Thawte Premium Server CA.pem" (installed with trust extract-compat).
PEAP version: auto.
Inner auth: MSCHAPv2.
Username: <myusername>
Pass: <mypass>
Comment by rimaille (ekyo) - Friday, 11 December 2015, 09:16 GMT
Same here, with :
core/wpa_supplicant 1:2.5-1
core/netctl 1.11-1

-> no nm

error in journal when trying to connect :
déc. 10 20:53:56 ix wpa_actiond[361]: Error (wlan0): Could not attach to wpa_supplicant

Restarting wpa_supplicant.service is OK, but i still cannot connect to my wifi AP : same error

déc. 10 21:07:46 ix systemd[1]: Stopped WPA supplicant.
déc. 10 21:07:46 ix systemd[1]: Starting WPA supplicant...
déc. 10 21:07:46 ix systemd[1]: Started WPA supplicant.
déc. 10 21:07:46 ix wpa_supplicant[1307]: Successfully initialized wpa_supplicant

systemctl restart netctl-auto@wlan0.service fail :

déc. 10 21:09:04 ix netctl-auto[1329]: Could not create the configuration file for interface 'wlan0'
déc. 10 21:09:04 ix systemd[1]: netctl-auto@wlan0.service: Control process exited, code=exited status=1
déc. 10 21:09:04 ix systemd[1]: netctl-auto@wlan0.service: Unit entered failed state.
déc. 10 21:09:04 ix systemd[1]: netctl-auto@wlan0.service: Failed with result 'exit-code'.

So, i downgraded wpa_supplicant :
[2015-12-11 09:54] [PACMAN] Running 'pacman -U wpa_supplicant-2.3-1-x86_64.pkg.tar.xz'
[2015-12-11 09:54] [ALPM] transaction started
[2015-12-11 09:54] [ALPM] downgraded wpa_supplicant (1:2.5-1 -> 2.3-1)
[2015-12-11 09:54] [ALPM] transaction completed

Restarting wpa_supplicant.service is ok, but restarting netctl-auto@wlan0.service is still KO.
So, i restarted my laptop and after reboot everything went right, connect is ok.

I stay available to every action which could help resolving the problem.
Comment by rimaille (ekyo) - Friday, 11 December 2015, 14:27 GMT
This issue was already present in wpa_supplicant 2.4 release : cf. https://bbs.archlinux.org/viewtopic.php?id=196584
A lot of persons have the same problem, they confirm the bug is back in 2.5.

A bug ticket was closed as duplicate with the same bug : https://bugs.archlinux.org/task/47311

I tried to go with 2.4, problem is there, so i downgraded to 2.3
Comment by rimaille (ekyo) - Friday, 11 December 2015, 15:15 GMT
The ticket for 2.4 bug was reopened https://bugs.archlinux.org/task/44731 , i think we can close this one.

Loading...