Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47318 - [kwin] crash on startup

Attached to Project: Arch Linux
Opened by marlemion (marlemion) - Thursday, 10 December 2015, 10:15 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 10 December 2015, 20:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: kwin_x11 and kwin_wayland both crash on startup with the following message:

kwin_x11: symbol lookup error: /usr/lib/libkwin4_effect_builtins.so.1: undefined symbol: _ZN8KWayland6Server16SurfaceInterface22slideOnShowHideChangedEv

Thus compositing does not work neither does the windowing system (obviously).

This happened after update from latest 5.4 to 5.5.0-2

I am running an Intel i5 system (Acer Aspire 7750G) with a Radeon HD 6850M (current Mesa driver)

Steps to reproduce:

Start Plasma 5.


This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 10 December 2015, 20:38 GMT
Reason for closing:  Not a bug
Comment by kkl2401 (kkl2401) - Thursday, 10 December 2015, 14:30 GMT
  • Field changed: Percent Complete (100% → 0%)
Can we have at least a comment why this is "not a bug"? I have the same problem and no idea what I'm doing wrong or how to fix it. Thanks.
Comment by J. Andrew Lanz-O'Brien (jlanzobr) - Thursday, 10 December 2015, 16:17 GMT
  • Field changed: Percent Complete (100% → 0%)
This happens to me too.
Comment by Doug Newgard (Scimmia) - Thursday, 10 December 2015, 16:19 GMT
A lot of people seeing this, so I reopened. My question to all of them, is your system completely up to date and have you rebuilt everything listed in pacman -Qm?
Comment by marlemion (marlemion) - Thursday, 10 December 2015, 16:22 GMT
Check wether some k**-git packages are still installed. In my case it was kwayand-git what was required by kdeconnect-git. Now I switched back kdeconnect and kwayland. Works now (apart from new glitches introduced (again) by KDE folks). I consider switching the DE.
Comment by Lars Veldscholte (Compizfox) - Thursday, 10 December 2015, 17:39 GMT
I had the same problem. Marlemion's suggestion works: I had kwayland-git installed (probably because of kdeconnect-git) I replaced it with kwayland and now kwin is working again. And, apparently kdeconnect-git works with the regular kwayland now.
Comment by Sebastian (anomander) - Thursday, 10 December 2015, 20:32 GMT
kwayland-git was the problem for me, too. Thx for the hint

Loading...