Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47300 - [librsvg] Crashes Cairo Dock when Steam window is opened

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Tuesday, 08 December 2015, 18:17 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 08 December 2015, 18:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After the update of librsvg to 2.40.12 I encountered the following problem: If Steam is launched, Cairo Dock crashes with the following error:

cairo-dock: cairo-surface.c:928: cairo_surface_reference: Assertion »(_cairo_atomic_int_get (&(&surface->ref_count)->ref_count) > 0)« failed.

After some testing it turned out that if Steam is minimized to tray Cairo doesn't crash, but if some dialog or window of Steam is shown, Cairo crashes with above error. Downgrading librsvg to 2.40.11 solves the problem.

A similar problem has been reported here: https://www.linux.org.ru/forum/general/12167468 Deadbeef crashes with the same error and again the problem is solved by a downgrade of librsvg.

Additional info:
* librsvg 2.40.12, cairo-dock 3.4.1-2, steam 1.0.0.51-1
Steps to reproduce:
* run Cairo Dock, then launch Steam
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 08 December 2015, 18:37 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#47245 

Loading...