Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47261 - [sshuttle] 0.73 breaks if -v option not used.

Attached to Project: Arch Linux
Opened by Alphazo (alphazo) - Friday, 04 December 2015, 13:34 GMT
Last edited by Felix Yan (felixonmars) - Thursday, 17 December 2015, 02:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since I have updated my system with the packages found at the end of this post I have noticed that my shuttle 0.73.1 [community] breaks:

#sshuttle --dns -r mybox 0/0
Traceback (most recent call last):
File "/usr/bin/sshuttle", line 9, in <module>
load_entry_point('sshuttle==0.73', 'console_scripts', 'sshuttle')()
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 568, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2720, in load_entry_point
return ep.load()
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2380, in load
return self.resolve()
File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2386, in resolve
module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/usr/lib/python3.5/site-packages/sshuttle/__main__.py", line 212, in <module>
opt.syslog, opt.daemon, opt.pidfile)
File "/usr/lib/python3.5/site-packages/sshuttle/client.py", line 502, in main
debug1('Starting sshuttle proxy.\n')
File "/usr/lib/python3.5/site-packages/sshuttle/helpers.py", line 21, in debug1
if verbose >= 1:
TypeError: unorderable types: NoneType() >= int()

Now if I just add an option for verbose, sshuttle works again:

sshuttle --dns -v -r mybox 0/0
Starting sshuttle proxy.
firewall manager ready method name nat.
UDP enabled: False
TCP redirector listening on ('127.0.0.1', 12300).
DNS listening on ('127.0.0.1', 12300).
c : connecting to server...
s: latency control setting = True
s: available routes:
s: 2/192.168.1.100/32
s: 2/10.8.0.2/32
s: 2/192.168.1.104/32
s: 2/62.212.70.0/24
s: 2/10.8.0.0/24
c : connected.
Connected.
firewall manager: starting transproxy.
....

I then installed the git version and it works just fine without any -v option. Looking at the commit history you will find a lot of fixes related to Python following the official 0.73 release


Here is my update log.
======


core/bash 4.3.042-3 3 -> 4
extra/apache 2.4.17-3 3 -> 4
extra/breeze-icons 5.16.0-1 1 -> 2
extra/cmake 3.4.0-1 1 -> 2
extra/graphviz 2.38.0-6 6 -> 7
extra/inkscape 0.91-12 12 -> 13
extra/libpaper 1.1.24-8 8 -> 9
extra/plasma-framework 5.16.0-1 1 -> 2
extra/xf86-input-evdev 2.10.0-1 1 -> 2
extra/xf86-input-synaptics 1.8.3-1 1 -> 2
extra/xf86-video-intel 1:2.99.917+478+gdf72bc5-2 2 -> 3
community/cutegram 2.7.0-3 3 -> 5
community/python-path 8.1.2-1 1 -> 2
community/telegramqml 0.9.1-1 1 -> 3
aur/chm2pdf 0.9.1-2 2 -> 4
aur/gimp-script-antique-border 0.24-1 1 -> 2
aur/gimp-script-che-guevara 0.24-1 1 -> 2
aur/gimp-script-color-tint 0.24-1 1 -> 2
aur/gimp-script-cyanotype 0.24-1 1 -> 2
aur/gimp-script-difference-layers 0.24-1 1 -> 2
aur/gimp-script-erosion-sharpen 0.24-1 1 -> 2
aur/gimp-script-error-level-analysis 0.24-1 1 -> 2
aur/gimp-script-escape-lines 0.24-1 1 -> 2
aur/gimp-script-film-grain 0.24-1 1 -> 2
aur/gimp-script-first-photo-border 0.24-1 1 -> 2
aur/gimp-script-glass-displacement 0.24-1 1 -> 2
aur/gimp-script-lomo 0.24-1 1 -> 2
aur/gimp-script-movie-300 0.24-1 1 -> 2
aur/gimp-script-national-geographic 0.24-1 1 -> 2
aur/gimp-script-obama-hope 0.24-1 1 -> 2
aur/gimp-script-photochrom 0.24-1 1 -> 2
aur/gimp-script-rainy-landscape 0.24-1 1 -> 2
aur/gimp-script-split-tone 0.24-1 1 -> 2
aur/gimp-script-sprocket-hole 0.24-1 1 -> 2
aur/gimp-script-sunny-landscape 0.24-1 1 -> 2
aur/gimp-script-technicolor-2-color 0.24-1 1 -> 2
aur/gimp-script-technicolor-3-color 0.24-1 1 -> 2
aur/gimp-script-up-down 0.24-1 1 -> 2
aur/gimp-script-vintage-look 0.24-1 1 -> 2
aur/gimp-script-white-balance-puzzle 0.24-1 1 -> 2
aur/gitso 0.6-3 3 -> 4
aur/htmldoc 1.8.28-1 1 -> 2
aur/jdownloader2 latest-5 5 -> 7
aur/libcurl-compat 7.23.1-2 2 -> 3
aur/libdbusmenu-gtk2 12.10.2-3 3 -> 4
aur/python2-pysvn 1.7.10-1 1 -> 2

==> Updated packages (new revision) :
core/dbus 1.10.2-1 -> 1.10.4-1
core/device-mapper 2.02.133-1 -> 2.02.136-1
core/glib2 2.46.1-1 -> 2.46.2-2
core/gnutls 3.4.6-1 -> 3.4.7-1
core/kmod 21-2 -> 22-1
core/libdbus 1.10.2-1 -> 1.10.4-1
core/libsystemd 227-1 -> 228-3
core/libutil-linux 2.27-6 -> 2.27.1-1
core/lvm2 2.02.133-1 -> 2.02.136-1
core/nano 2.4.2-2 -> 2.4.3-1
core/pacman-mirrorlist 20151115-1 -> 20151122-1
core/systemd 227-1 -> 228-3
core/systemd-sysvcompat 227-1 -> 228-3
core/util-linux 2.27-6 -> 2.27.1-1
extra/atkmm 2.24.1-1 -> 2.24.2-1
extra/audacity 2.1.0-1 -> 2.1.1-1
extra/babl 0.1.12-1 -> 0.1.14-1
extra/blas 3.5.0-1 -> 3.6.0-2
extra/cblas 3.5.0-3 -> 3.6.0-2
extra/chromium 46.0.2490.86-1 -> 47.0.2526.73-1
extra/clamav 0.98.7-3 -> 0.99-1
extra/cups 2.1.0-1 -> 2.1.2-1
extra/cups-filters 1.1.0-4 -> 1.2.0-1
extra/enblend-enfuse 4.1.3-6 -> 4.1.4-1
extra/epiphany 3.18.0-1 -> 3.18.1-1
extra/ffmpeg 1:2.8.2-1 -> 1:2.8.3-1
extra/folks 0.11.1-2 -> 0.11.2-1
extra/freetype2 2.6.1-1 -> 2.6.2-1
extra/gegl 0.3.0-2 -> 0.3.4-1
extra/gimp 2.8.14-4 -> 2.8.16-1
extra/git 2.6.2-1 -> 2.6.3-1
extra/glibmm 2.46.1-1 -> 2.46.2-1
extra/gnome-disk-utility 3.18.2-1 -> 3.18.3.1-1
extra/gssdp 0.14.11-1 -> 0.14.12.1-1
extra/gvim 7.4.884-1 -> 7.4.944-1
extra/harfbuzz 1.1.0-1 -> 1.1.2-1
extra/harfbuzz-icu 1.1.0-1 -> 1.1.2-1
extra/hplip 3.15.9-2 -> 3.15.11-1
extra/imagemagick 6.9.2.4-1 -> 6.9.2.6-1
extra/intel-tbb 4.4_20150728-1 -> 4.4_20151115-1
extra/lapack 3.5.0-1 -> 3.6.0-2
extra/libchamplain 0.12.11-1 -> 0.12.12-1
extra/libcups 2.1.0-1 -> 2.1.2-1
extra/libetonyek 0.1.3-1 -> 0.1.4-1
extra/libgit2 1:0.23.3-1 -> 1:0.23.4-1
extra/libkolabxml 1.1.1-2 -> 1.1.2-1
extra/libmariadbclient 10.0.22-1 -> 10.1.9-2
extra/libnm-glib 1.0.7-1 -> 1.0.8-1
extra/librsvg 1:2.40.11-1 -> 1:2.40.12-1
extra/libtracker-sparql 1.6.0-2 -> 1.6.1-1
extra/lua 5.3.1-1 -> 5.3.2-1
extra/mariadb 10.0.22-1 -> 10.1.9-2
extra/mariadb-clients 10.0.22-1 -> 10.1.9-2
extra/mesa 11.0.5-1 -> 11.0.6-1
extra/mesa-libgl 11.0.5-1 -> 11.0.6-1
extra/mkvtoolnix-cli 8.5.2-1 -> 8.6.1-1
extra/mkvtoolnix-gui 8.5.2-1 -> 8.6.1-1
extra/mono 4.0.4.1-1 -> 4.2.1.102-1
extra/networkmanager 1.0.7-1 -> 1.0.8-1
extra/network-manager-applet 1.0.6-1 -> 1.0.8-1
extra/networkmanager-openconnect 1.0.2-2 -> 1.0.8-1
extra/networkmanager-openvpn 1.0.6-2 -> 1.0.8-1
extra/networkmanager-pptp 1.0.6-1 -> 1.0.8-1
extra/networkmanager-vpnc 1.0.6-1 -> 1.0.8-1
extra/nm-connection-editor 1.0.6-1 -> 1.0.8-1
extra/opus 1.1-1 -> 1.1.1-1
extra/prison-frameworks 1.1.1.20141027-1 -> 1.2.1.20150831-1
extra/python2-setuptools 1:18.5-1 -> 1:18.7.1-1
extra/python2-urwid 1.3.0-3 -> 1.3.1-2
extra/python-setuptools 1:18.5-1 -> 1:18.7.1-1
extra/smplayer 15.9.0-1 -> 15.11.0-1
extra/thunderbird 38.3.0-3 -> 38.4.0-1
extra/thunderbird-i18n-fr 38.3.0-1 -> 38.4.0-1
extra/vim-runtime 7.4.884-1 -> 7.4.944-1
extra/xf86-input-wacom 0.31.0-1 -> 0.32.0-1
extra/xorg-server 1.17.4-2 -> 1.18.0-3
extra/xorg-server-common 1.17.4-2 -> 1.18.0-3
extra/xorg-server-xwayland 1.17.4-2 -> 1.18.0-3
community/aircrack-ng 1.2rc2-1 -> 1.2rc3-1
community/cinnamon-desktop 2.6.5-1 -> 2.8.0-1
community/cinnamon-translations 2.6.3-1 -> 2.8.2-1
community/cjs 2.6.2-1 -> 2.8.0-1
community/docker 1:1.9.0-1 -> 1:1.9.1-1
community/fpc 2.6.4-1 -> 3.0.0-1
community/geany 1.25-1 -> 1.26-1
community/geany-plugins 1.25-3 -> 1.26-1
community/gst-editing-services 1.6.0-1 -> 1.6.1-1
community/libqtelegram-ae 2:6.0-3 -> 3:6.0-3
community/mbedtls 2.1.3-1 -> 2.2.0-1
community/muffin 2.6.1-1 -> 2.8.4-1
community/nemo 2.6.7-1 -> 2.8.5-1
community/nemo-fileroller 2.6.0-3 -> 2.8.0-1
community/nemo-preview 2.6.0-3 -> 2.8.0-1
community/npm 3.4.0-1 -> 3.5.0-1
community/pitivi 0.94-2 -> 0.95-3
community/python2-pysqlite 2.6.3-5 -> 2.8.1-2
community/python-sphinx 1.3.1-10 -> 1.3.3-3
community/qupzilla 1.8.8-1 -> 1.8.9-1
community/sshuttle 0.72-1 -> 0.73-1
community/syncthing 0.12.3-1 -> 0.12.6-1
community/tint2 0.12.2-1 -> 0.12.3-1
community/tor 0.2.6.10-1 -> 0.2.7.5-1
community/toxcore 3652-1 -> 3661-1
community/virtualbox 5.0.8-2 -> 5.0.10-1
community/virtualbox-guest-iso 5.0.8-1 -> 5.0.10-1
community/virtualbox-host-modules 5.0.8-2 -> 5.0.10-2.1
community/virtualbox-host-modules-lts 5.0.8-2 -> 5.0.10-1
multilib/lib32-mesa 11.0.5-1 -> 11.0.6-1
multilib/lib32-mesa-libgl 11.0.5-1 -> 11.0.6-1
aur/artefetcher-qt5 0.6.5-1 -> 0.7.0-1
aur/aura-bin 1.3.2.1-1 -> 1.3.4-1
aur/byobu 5.97-1 -> 5.98-1
aur/google-chrome 46.0.2490.86-1 -> 47.0.2526.73-1
aur/java-service-wrapper 3.5.26-1 -> 3.5.27-1
aur/lib32-libpng12 1.2.53-1 -> 1.2.54-2
aur/libnfc 1.7.0-1 -> 1.7.1-3
aur/libpng12 1.2.53-1 -> 1.2.54-2
aur/mfoc 0.10.6-1 -> 0.10.7-2
aur/osm-gps-map-gtk3 1.0.2-2 -> 1.1.0-2
aur/pdftk-bin 2.02_2-1 -> 2.02_3-2
aur/pond-git 429.355c99c-1 -> 439.f422bc3-1
aur/prezto-git r1494.f2a826e-1 -> r1557.32f3b57-1
aur/python-llfuse 0.41-1 -> 0.41.1-1
aur/python2-pypdf2 1.24-1 -> 1.25.1-1
aur/python2-socks 1.5.0-1 -> 1.5.6-1
aur/rabbitvcs 0.15.3-1 -> 0.16-1
aur/rabbitvcs-nemo 0.15.3-2 -> 0.16-2
aur/spotify 1.0.17.75-2 -> 1.0.19.106-1
aur/syncany 0.4.6_alpha-1 -> 0.4.7_alpha-2
aur/uberwriter 12.07.3-5 -> 15.05.01-1
aur/ultrastardx-svn 1:2973M-1 -> 1:3068-1
aur/virtualbox-ext-oracle 5.0.8-1 -> 5.0.10-1

==> New packages:
extra/dcadec 0.1.0-1 (requis par -)
community/python-cycler 0.9.0-1 (requis par python-matplotlib)
community/python-dateutil 2.4.2-2 (requis par python-matplotlib)
community/python-matplotlib 1.5.0-1 (requis par pitivi)
community/python-pyparsing 2.0.5-1 (requis par python-matplotlib)
This task depends upon

Closed by  Felix Yan (felixonmars)
Thursday, 17 December 2015, 02:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.73.20151209-1
Comment by Felix Yan (felixonmars) - Friday, 04 December 2015, 17:08 GMT
Known issue, will be fixed in next release.

https://github.com/sshuttle/sshuttle/issues/31

Loading...