Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47241 - [systemd] 228 makes X server fail to start with custom /tmp mount options

Attached to Project: Arch Linux
Opened by trendkiller (trendkiller) - Wednesday, 02 December 2015, 22:06 GMT
Last edited by Dave Reisner (falconindy) - Friday, 04 December 2015, 19:07 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After i upgraded systemd from 227 to 228, when i use custom mount options for /tmp, the X server fails to start on boot with the following message:
Fatal server error:
(EE) Could not create lock file in /tmp/.tx0-lock

Then goes into a loop trying to start and failing.

My fstab entry:

tmpfs /tmp tmpfs rw,nodev,nosuid,mode=1700

These options worked fine with systemd 227.
After i comment out the fstab entry it works with 228 too.


This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 04 December 2015, 19:07 GMT
Reason for closing:  Not a bug
Additional comments about closing:  mode=1700 does what it says on the tin.
Comment by Dave Reisner (falconindy) - Thursday, 03 December 2015, 00:32 GMT
Is this a typo? Did you mean systemd 227/228? Do the effective mount options differ (in /proc/self/mountinfo) between 227 and 228?
Comment by Doug Newgard (Scimmia) - Thursday, 03 December 2015, 04:05 GMT
mode=1700 on /tmp seems like a very bad idea to me. Is that the option causing problems?
Comment by trendkiller (trendkiller) - Thursday, 03 December 2015, 10:13 GMT
It's a typo, i meant 227/228. there seems to be no way to edit the original post :/
why is mode=1700 a bad idea? it worked fine until systemd 228 upgrade
Comment by Dave Reisner (falconindy) - Thursday, 03 December 2015, 12:17 GMT
1700 is a bad idea because it refuses write access to anyone but root. I'm surprised more basic things haven't broken for you.

I asked for the difference in effective mount options because it seems to me like 228 has the *correct* behavior in actually honoring your mount options.
Comment by trendkiller (trendkiller) - Friday, 04 December 2015, 19:06 GMT
1700 was indeed the problem. As the other options work fine without it. I guess this can be closed...

Loading...