Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47206 - [mesa] OpenGL freezing on first frame

Attached to Project: Arch Linux
Opened by webnull (webnull) - Saturday, 28 November 2015, 09:52 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 05 December 2015, 12:23 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

I have freezes on OpenGL on my integrated graphics card. The hardware is Dell Inspirion 5537.

```
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
Subsystem: Dell Device 05ea
Flags: bus master, fast devsel, latency 0, IRQ 43
Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
Memory at b0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 5000 [size=64]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915
```

After normally booting up KDE using startx (KWin uses XRender for compositions, so it's not hanging up like it is on OpenGL) I'm trying to launch eg. glxgears, or AOE: II on Wine, Opera or Chromium. Every application that uses GPU acceleration/OpenGL is immediately hanging up on first rendered frame.

The same is on Wayland, when I run "weston" instead of startx then I see a black screen.

Sometimes when I run my computer I have fully working OpenGL/GPU acceleration, randomly sometimes it just works, I don't know why.

I tried kernel switches:

```
damian@arch ~ $ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-linux-git root=UUID=f25da354-37fc-4b94-8a7a-b725b5eed880 rw resume=/dev/disk/by-uuid/a0309609-e78c-46bb-b87a-8a0217528592 splash acpi_backlight=vendor acpi_osi=Linux intel_pstate=disable i915.semaphores=1 i915.enable_execlists=0
```

Three different kernels:
- linux (4.2.5-1)
- linux-lts (4.1.13-1)
- linux-git (4.4.0-rc2-g03018ac)

In /etc/X11/xorg.conf I tried two configuration options:

```
Option "AccelMethod" "uxa" # there was also an alternative value, but with it I didn't notice even first frame rendered
Option "TearFree" "true"
```

I really gived up, I cannot use Chromium and Opera. I have to use Firefox. I lost all my bookmarks with it. Shit happens.

Is it a bug when no any internet/forum tips works?

Thanks, have a nice day,
Damian
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 05 December 2015, 12:23 GMT
Reason for closing:  None
Comment by webnull (webnull) - Thursday, 03 December 2015, 19:33 GMT
I resolved the issue.
In previous kernel versions I had to use "acpi_backlight=vendor acpi_osi=Linux" to have correct support for hibernate, suspend and backlight (I had to write a script that was configuring backlight from shell, as it wasnt working in system).

After recent ACPI changes in kernel I can regulate backlight by system, and the hack is no longer needed. But currently randomly my laptop cannot suspend and hibernate, it's just hanging up with a black screen or with screen turned off. After force shutdown I have problems with filesystem which is getting repaired by fsck, but anyway I see corrupted files on disk, eg. recently mpd.service got corrupted which is reported by systemd during boot. I'm afraid that in meantime any important file from /bin, /lib, /usr/lib or /sbin will be corrupted, then I will not be able to boot up the system.

Also rebooting/shuting down not always working. It's also staying with black screen, it's like using "halt". It will finish up everything, halt the system but not power off.

Regarding hibernation there is also other ACPI issue: If it hibernates then after booting up there is a possibility that after loading hibernation image I will get a black screen.

Loading...