Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#47151 - xorg-server 1.18 and Nvidia Optimus

Attached to Project: Arch Linux
Opened by Jamp (jamp) - Sunday, 22 November 2015, 23:21 GMT
Last edited by Laurent Carlier (lordheavy) - Wednesday, 24 February 2016, 19:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Sven-Hendrik Haase (Svenstaro)
Laurent Carlier (lordheavy)
Felix Yan (felixonmars)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 42
Private No



Disabling switchable graphics does not work anymore

With the xorg upgrade I downloaded this morning the instructions
to disable the switchable graphics (
do not work anymore

My xorg.conf is as below

Section "ServerLayout"
Identifier "Layout0"
Inactive "intel"
Screen 0 "NVIDIA"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "yes"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "AllowEmptyInitialConfiguration"
BusID "PCI:1:0:0"

Section "Device"
Identifier "INTEL"
Driver "modesetting"
Option "AccelMethod" "none"
BusID "PCI:0:2:0"

Section "Screen"
Identifier "NVIDIA"
Device "nvidia"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24

Section "Screen"
Identifier "INTEL"
Device "intel"

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Wednesday, 24 February 2016, 19:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  See comments
Comment by scott (acp0112) - Monday, 23 November 2015, 00:05 GMT
I am experiencing the same issue. Once X server starts the screen is no longer updated. I have attached my conf and log file. Let me know if I can provide any more useful information.
Comment by cheng (fzshot) - Monday, 23 November 2015, 05:06 GMT
I have the same issue as well. By replacing Screen 0 "NVIDIA" to Screen 1 "NVIDIA" could get the screen working (at least on my laptop). However, I decided to downgrade to the older version and waiting for update.
Comment by polospartan (polospartan) - Monday, 23 November 2015, 07:32 GMT
@cheng Thanks for the workaround, it works for me too !
Comment by Kevin (kevin) - Monday, 23 November 2015, 11:23 GMT
Same issue here, workaround mentioned by cheng worked for me too.
Been up all night troubleshooting, found out that if you don't specify Screen 1 it will log in Xorg.*.log that there are no configurations for Screen 1. Also found out xorg-xrandr utility is version 1.4.3 and Server randr package is 1.5 (Maybe this could be the culprit).

I also found out that if using Screen 1, LightDM would start but I only get a black screen with a single pixel dot in the upperleft corner. I can use my password to log-in blindly but after that X session crashes and I'll be returned to LightDM with the same screen of the single pixel dot.

Since this happened during configuration tasks after installing, I started over using Nouveau for now.
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 24 November 2015, 07:48 GMT
Did you guys try the nvidia driver integrated device switching mechanism? It's supposed to be able to replace Optimus eventually.
Comment by Łukasz Pożarlik (pozar87) - Tuesday, 24 November 2015, 12:23 GMT
I also had problem with multi-head setup on 1.18 (one laptop display and two external displays connected through docking station - achieved by bumblebee). For now I just revert to last working packages:


Perhaps someone may need this list :)
Best Regards,

PS @Sven-Hendrik - you refer to PRIME?
Comment by Sven-Hendrik Haase (Svenstaro) - Tuesday, 24 November 2015, 12:35 GMT
Yes, prime. Is that working well yet?
Comment by Vidgen Villalva (vidgen) - Wednesday, 25 November 2015, 09:47 GMT
@cheng Thanks for the workaround. The only thing is, when I start mate, when I open any window it comes up on the top left corner and very small. I have to resize it. I tried changing the mate window properties to center it but id doesn't help.
Comment by ux (ubitux) - Wednesday, 25 November 2015, 10:13 GMT
The screen 0/1 workaround is breaking many things, such as dmenu in i3, and obviously steam games in various ways. PRIME is unfortunately not a solution when performance is involved.
Comment by Sam Stoelinga (samos123) - Friday, 27 November 2015, 18:07 GMT
I'm using LightDM with latest Nvidia prop drivers. I also used downgrade workaround with:

cd /var/cache/pacman/pkg/
sudo pacman -U xorg-server-1.17.4-2-x86_64.pkg.tar.xz xf86-input-evdev-2.10.0-1-x86_64.pkg.tar.xz xf86-input-synaptics-1.8.3-1-x86_64.pkg.tar.xz

Related forum thread which mentioned the workaround:
Comment by Koen Rousseau (DrPeecy) - Saturday, 28 November 2015, 09:06 GMT
Downgrading as per samos123's instructions works, but I found I needed to remove /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass.conf before downgrading. That file gets recreated automatically after the downgrade, so no worries.

Hope someone will fix the xorg-server package soon...

If you want to be able to upgrade your system in the meantime, add this line to /etc/pacman.conf:

IgnorePkg = xorg-server xf86-input-evdev xf86-input-synaptics
Comment by vincent (humhumhum) - Sunday, 29 November 2015, 11:18 GMT
same pb here with my lenovo Y50
Comment by Matt Runion (mrunion) - Saturday, 05 December 2015, 05:37 GMT
To clarify, it' not upgrading the nVidia drivers that's the issue, it's the Xorg server stuff us nVidia guys were ignoring recently, correct? I have this same issue if I upgrade as well.
Comment by Valentin PERRUSSEL (Nibel) - Thursday, 10 December 2015, 02:31 GMT
Same problem on MSI GE70 0ND.

Downgrade then add this to /etc/pacman.conf :
IgnorePkg = xf86-input-evdev xf86-input-joystick xf86-input-keyboard xf86-input-mouse xf86-input-synaptics xf86-input-void xf86-video-intel xf86-video-vesa xorg-server xorg-server-common xorg-server-xephyr

Wait for an Optimus support.
Comment by Stefan (vollekannehoschi) - Saturday, 12 December 2015, 16:59 GMT
Same Problem here, I get the same "Screen 1" error in Xorg.log. I have no Optimus, but two graphic devices with fixed wires to internal display and external connections (HDMI, DisplayPort).

Notebook Model: HP ZBook 15 G2 Basic
graphics card: NVIDIA Quadro K2100M
CPU: Intel Core i7-4810MQ 4C
Comment by ux (ubitux) - Monday, 14 December 2015, 10:08 GMT
Just in order to summarize:

- xorg-1.17 + nvidia-358.16 works
- xorg 1.18 + nvidia-358.16 doesn't work

According to you only need a configuration such as:

% cat /etc/X11/xorg.conf
Section "Module"
Load "modesetting"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:4:0:0"
Option "AllowEmptyInitialConfiguration"


% lspci|grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
04:00.0 VGA compatible controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1)

This simple configuration actually allows to start both xorg 1.17 and xorg 1.18. With xorg 1.18 it has the exact same effect as replacing "Screen 0" with "Screen 1" in the old configuration.

The undesirable effects I personally noticed within a few seconds are:
- dmenu broken: it doesn't show up all the time, most likely on another screen I can't see (I'm using i3, starting X with a startx)
- running Steam will popup 1/4 of the login window on the top left of the screen
- games ran by steam such as CS:GO will be extremely confused by the screen layout and you are simply not be able to play

In order to rollback:
% cd /var/cache/pacman/pkg
# pacman -U xf86-input-evdev-2.10.0-1-x86_64.pkg.tar.xz xf86-input-keyboard-1.8.1-1-x86_64.pkg.tar.xz xf86-input-mouse-1.9.1-1-x86_64.pkg.tar.xz xf86-input-vmmouse-13.1.0-1-x86_64.pkg.tar.xz xf86-input-void-1.4.1-1-x86_64.pkg.tar.xz xf86-video-ark-0.7.5-6-x86_64.pkg.tar.xz xf86-video-ati-1:7.5.0-2-x86_64.pkg.tar.xz xf86-video-dummy-0.3.7-4-x86_64.pkg.tar.xz xf86-video-fbdev-0.4.4-4-x86_64.pkg.tar.xz xf86-video-glint-1.2.8-6-x86_64.pkg.tar.xz xf86-video-i128-1.3.6-6-x86_64.pkg.tar.xz xf86-video-intel-1:2.99.917+478+gdf72bc5-2-x86_64.pkg.tar.xz xf86-video-mach64-6.9.5-1-x86_64.pkg.tar.xz xf86-video-neomagic-1.2.9-1-x86_64.pkg.tar.xz xf86-video-nouveau-1.0.11-3-x86_64.pkg.tar.xz xf86-video-nv-2.1.20-6-x86_64.pkg.tar.xz xf86-video-openchrome-0.3.3-5-x86_64.pkg.tar.xz xf86-video-r128-6.10.0-1-x86_64.pkg.tar.xz xf86-video-savage-2.3.8-1-x86_64.pkg.tar.xz xf86-video-siliconmotion-1.7.8-1-x86_64.pkg.tar.xz xf86-video-sis-0.10.8-1-x86_64.pkg.tar.xz xf86-video-tdfx-1.4.5-6-x86_64.pkg.tar.xz xf86-video-trident-1.3.7-1-x86_64.pkg.tar.xz xf86-video-vesa-2.3.4-1-x86_64.pkg.tar.xz xf86-video-vmware-13.1.0-2-x86_64.pkg.tar.xz xf86-video-voodoo-1.2.5-6-x86_64.pkg.tar.xz xorg-server-1.17.4-2-x86_64.pkg.tar.xz

And to prevent further upgrades, "IgnoreGroup = xorg" in /etc/pacman.conf is enough.

I didn't find any related Xorg bug report. Is anyone actually aware of anything on the Xorg side?

Note: this bug severity should be at least High.
Comment by Alex (ggppdd) - Wednesday, 16 December 2015, 13:10 GMT
@ ux (ubitux)
To get rid of undesirable effects you mentioned add
Option "nvidiaXineramaInfo" "False"
to xorg.conf's "Device" section.
I guess it's i3 related.
Comment by ux (ubitux) - Wednesday, 16 December 2015, 14:13 GMT
@Alex (ggppdd)
That indeed works pretty well. Thanks.

Edit: actually... firefox is completely broken (left click not working, UI half dead, ...). Not sure if it's because of the xinerama thing or not.
Comment by mateo_ (mateo_) - Thursday, 17 December 2015, 19:30 GMT
Same issue here, firefox was completely broken has mentionned above (on both fluxbox and i3). I had to roll back to xorg 1.17.

My hardware: Intel(R) Core(TM) i7-4710HQ CPU @ 2.50GHz + Nvidia Geforce GTX 860M.

Comment by Alex (ggppdd) - Thursday, 17 December 2015, 19:36 GMT
Try enter and then exit floating mode (mod-shift-space) as temporary solution.
Comment by ux (ubitux) - Monday, 28 December 2015, 11:47 GMT
Playing with the floating mode doesn't help. Also, it can actually be replicated with fluxbox, so it's likely unrelated.

Reproducing the bug is pretty easy with Firefox: left click simply doesn't respond, or clicking toolbar buttons such as the preferences are ignored (the hover event is working though).
Comment by Łukasz Pożarlik (pozar87) - Thursday, 07 January 2016, 07:06 GMT
I decided to give another shot and update the system. And surprisingly this time it worked :) I'm not sure what was the reason of the failure - but what I'm sure I didn't touch any of the xorg configuration files.
The list of packages which I'm currently running:
xorg-server-common 1.18.0-3
xorg-server-xvfb 1.18.0-3
nvidia 358.16-3
nvidia-utils 358.16-1
Comment by ux (ubitux) - Thursday, 07 January 2016, 09:08 GMT
Still broken:

Section "Module"
Load "modesetting"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:4:0:0"
Option "AllowEmptyInitialConfiguration"

==> dmenu+steam broken

Section "Module"
Load "modesetting"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:4:0:0"
Option "AllowEmptyInitialConfiguration"
Option "nvidiaXineramaInfo" "False"

==> firefox broken
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 07 January 2016, 10:22 GMT
Could someone test the new nvidia beta driver (from AUR perhaps) and report results?
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 07 January 2016, 13:11 GMT
I stuck the new driver into [testing]. Please test.
Comment by Rudolf Tilgass (rudzha) - Thursday, 07 January 2016, 13:28 GMT
I just tried the drivers from [testing].
Same result. GTK3 apps, dmenu, steam still broken.
Comment by Eray Aydın (erayaydin) - Friday, 08 January 2016, 16:33 GMT
Same problem with Dell Inspiron 3542. Before Xorg 1.17 everythings fine, after new Xorg version there is this problem.
Comment by Domino (bu.domino) - Monday, 11 January 2016, 10:39 GMT
Downgrading doesn't seem to work for me. glxspheres64 stops working due to a file error
Comment by Alex (ggppdd) - Monday, 11 January 2016, 15:10 GMT
This helps me with firefox:
Option "nvidiaXineramaInfoOverride" "1366x768+0+0, 1366x768+1366+0, 1366x768+0+768, 1366x768+1366+768"
Comment by AnAkkk (AnAkkk) - Monday, 11 January 2016, 20:23 GMT
Is nvidia even aware of this issue? Seems weird that they have not made any attempt to fix it yet while they're planning to add Prime synchronization in linux 4.5.

EDIT: Maybe someone should add aplattner to the CC list as he has an account here.
Comment by ux (ubitux) - Tuesday, 12 January 2016, 13:22 GMT
I confirm the workaround, nvidiaXineramaInfo=false isn't even necessary with the nvidiaXineramaInfoOverride. So finally, the following works for me so far:

Section "Module"
Load "modesetting"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:4:0:0"
Option "AllowEmptyInitialConfiguration"
#Option "nvidiaXineramaInfo" "False"
Option "nvidiaXineramaInfoOverride" "1920x1080+0+0, 1920x1080+1920+0, 1920x1080+0+1080, 1920x1080+1920+1080"

Note1: "nvidiaXineramaInfoOverride" "1920x1080+0+0" isn't enough for some reason, the whole thing looks necessary.

Note2: in the .xinitrc, I also need disable the laptop monitor if I use an external one (otherwise I get huge lag/glitches in the top of the screen). It looks like this:
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
xrandr --output eDP-1 --off

Thanks Alex for the workaround. I'm curious about what the XineramaInfo we are overriding actually look like though...
Comment by ux (ubitux) - Tuesday, 12 January 2016, 15:59 GMT
Actually, GTK3 apps are kind of broken. Like, scroll down menus in pavucontrol or vinagre are fucked up...
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 13 January 2016, 17:56 GMT
Please test 361.18 from [testing].
Comment by Munzir Taha (munzirtaha) - Wednesday, 13 January 2016, 20:05 GMT
I confirm that updating to 361.18 didn't solve any problem. Still firefox and the GTK3 drop-down menus are broken the same way as before
Comment by Soup (Soup) - Wednesday, 13 January 2016, 20:20 GMT
Did you also test with 'Screen 0 "nvidia"' by any chance?
Comment by Munzir Taha (munzirtaha) - Sunday, 24 January 2016, 05:19 GMT
qt4 apps are also broken, e.g vlc
Comment by Munzir Taha (munzirtaha) - Sunday, 24 January 2016, 12:20 GMT
eclipse starts very tiny (almost unseen) and I couldn't even maximize it. Is this related?
Comment by Valentin PERRUSSEL (Nibel) - Monday, 25 January 2016, 09:01 GMT
The workaround works for me atm (system full updat 01/25/2016 @ 9H00 GMT).

My /etc/X11/xorg.conf.d/20-nvidia.conf :

Section "Module"
Load "modesetting"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "DPI" "96 x 96"
Option "AllowEmptyInitialConfiguration"
Option "Coolbits" "31"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"
Option "nvidiaXineramaInfoOverride" "1600x900+0+0, 1600x900+1600+0, 1600x900+0+900, 1600x900+1600+900"

Fullscren window apps are a bit broken, they don't respect my tint2 bar (evertyime bedhind it... now i use autohide option to pass this).
Comment by Michael (Kamikaze84) - Wednesday, 03 February 2016, 01:29 GMT
Can someone confirm whether this bug is mainly due to the nvidia driver or if it is on the xorg side?

I frequently connect my laptop to different screens at work & at home, so the nvidiaXineramaInfoOverride workaround is bound to be a PITA.

Comment by ux (ubitux) - Wednesday, 03 February 2016, 21:56 GMT
Given that it works with Xorg 1.17 but not Xorg 1.18 with the same nvidia driver, the issue can be reported as a regression on Xorg side. That said, given the history of that company and its proprietary politic it's far possible nvidia was actually abusing the Xorg API in the first place. So most likely, both are at fault. But IMO Xorg is responsible for preventing any regression on its software, so my guess would be to report the issue at
Comment by Michael (Kamikaze84) - Friday, 05 February 2016, 00:01 GMT
Thanks. I've filed a bug here by summarising this report:
Comment by John C (tancrackers) - Friday, 05 February 2016, 02:46 GMT
I noticed that without a xorg.conf file, my X displays with nvidia installed with mesa-libgl but X does NOT start at all if I install nvidia-libgl.
Could it be that nvidia-libgl doesn't play nicely with X 1.18?
Comment by Iain (iainh) - Tuesday, 09 February 2016, 13:58 GMT
I was experiencing the same issue where windows would open very small in the upper left hand corner and context menus were just small squares in the upper left. Upgraded to xorg-server 1.18.1 this morning fixed the issue.

For anyone looking to reproduce it before the official package is out here is what I did:
- pulled xorg-server from abs
- bumped the pkgver to 1.18.1
- disabled the patches
- removed the dependency on mesa-libgl since I have nvidia-libgl installed
- built, installed, rebooted
Comment by Laurent Carlier (lordheavy) - Tuesday, 09 February 2016, 14:16 GMT

packages are in testing. Are you using modesetting or intel driver?
Comment by Iain (iainh) - Tuesday, 09 February 2016, 15:16 GMT

I'm using modesettings. Good to hear the packages have hit testing, hopefully this fixes everyone else's issue as it did mine.
Comment by Munzir Taha (munzirtaha) - Wednesday, 10 February 2016, 03:51 GMT
For me nothing has been changed with the new versions. All the bugs reported are still the same.

$pacman -Q xorg-server nvidia nvidia-libgl :(
xorg-server 1.18.1-2
nvidia 361.28-1
nvidia-libgl 361.28-1
Comment by Michael (Kamikaze84) - Wednesday, 10 February 2016, 08:11 GMT
I had a go trying the 'testing' packages this morning, nothing has changed for me either - still doesn't function.

I tried the basic config:

Section "Module"
Load "modesetting"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "AllowEmptyInitialConfiguration"
Comment by Munzir Taha (munzirtaha) - Wednesday, 10 February 2016, 11:29 GMT
Can you please test with eclipse software and confirm whether it opens well and paste your config file?
Comment by Iain (iainh) - Thursday, 11 February 2016, 02:53 GMT
My apologies, I thought I'd tested with the laptop display as well as an external monitor but it looks like it still doesn't work properly on the laptop display.
Comment by AnAkkk (AnAkkk) - Thursday, 11 February 2016, 09:12 GMT
A nvidia dev commented about the issue:

Apparently this was fixed in xorg git:

EDIT: Actually this is in Xorg 1.18.1, so might not be fixed.
Comment by Laurent Carlier (lordheavy) - Thursday, 11 February 2016, 09:59 GMT
This patch isn't included in xorg-server-1.18.1

I will push a new release in testing with this patch applied, please test (xorg-server-1.18.1-3)
Comment by Michael (Kamikaze84) - Thursday, 11 February 2016, 13:26 GMT
Initial indications are that xorg-server-1.18.1-3 appears to work for me, thanks!

I did have to remove some old symlinks and re-install libglvnd as there were some old symlinks screwing things up for me under /usr/lib/ (mainly for files like & but once I did that and used the basic config everything started OK.

@Munzir I tested eclipse. I just opened a project and resized the main window - worked fine.
Comment by Patrick Chilton (chpatrick) - Wednesday, 17 February 2016, 14:32 GMT
  • Field changed: Percent Complete (100% → 0%)
xorg-server-1.18.1-3 still doesn't work for me with this xorg.conf:

Section "ServerLayout"
Identifier "layout"
Screen 0 "nvidia"
Inactive "intel"

Section "Device"
Identifier "nvidia"
Driver "nvidia"
# Change BusID if necessary. Tips: (lspci | grep 3D) (Change 01:00.0 to 1:0:0)
BusID "PCI:1:0:0"

Section "Screen"
Identifier "nvidia"
Device "nvidia"
Option "AllowEmptyInitialConfiguration" "Yes"

Section "Device"
Identifier "intel"
Driver "modesetting"
# Change BusID if necessary. Tips: (lspci | grep VGA) (Change 00:02.0 to 0:2:0)
BusID "PCI:0:2:0"
Option "AccelMethod" "none"

Section "Screen"
Identifier "intel"
Device "intel"

This works fine with xorg-server-1.17.4-2.
Comment by Valentin PERRUSSEL (Nibel) - Wednesday, 17 February 2016, 15:04 GMT
@ Patrick Chilton
Update your xorg.conf read the wiki.
Comment by Matt Runion (mrunion) - Friday, 19 February 2016, 01:29 GMT
I also had this bug, and the latest updates fixed the issue. The xorg.conf instructions have changed, as Valentin has pointed out.