Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47071 - [gvfs] Nautilus does not show External HDD in Other Locations

Attached to Project: Arch Linux
Opened by Rongcui Dong (carldong) - Sunday, 15 November 2015, 07:23 GMT
Last edited by Jan de Groot (JGC) - Thursday, 01 September 2016, 09:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After this immediate upgrade of nautilus (2015-11-14, 23:13 Los Angeles Time), to libnautilus-extension-3.18.2-1 nautilus-3.18.2-1, external HDD are not shown in Other Locations. However, normal thumb drives still shows normally on the left panel.

Although HDDs are not shown, they are automatically mounted as usual, and I can still access them in two clicks from the Removable drive menu Extension

Additional info:
* libnautilus-extension-3.18.2-1 nautilus-3.18.2-1
* config and/or log files etc.

New log from journalctl:

Nov 14 23:17:42 rongcuiXPS13 kernel: scsi 11:0:0:0: Direct-Access TOSHIBA External USB 3.0 0001 PQ: 0 ANSI: 6
Nov 14 23:17:42 rongcuiXPS13 kernel: sd 11:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
Nov 14 23:17:42 rongcuiXPS13 kernel: sd 11:0:0:0: [sdb] Write Protect is off
Nov 14 23:17:42 rongcuiXPS13 kernel: sd 11:0:0:0: [sdb] Mode Sense: 33 00 00 08
Nov 14 23:17:42 rongcuiXPS13 kernel: sd 11:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
Nov 14 23:17:42 rongcuiXPS13 colord[611]: /usr/lib/colord/colord-sane: error while loading shared libraries: libsane.so.1: cannot open shared object file: No such file or directory
Nov 14 23:17:42 rongcuiXPS13 kernel: sdb: sdb1 sdb2
Nov 14 23:17:42 rongcuiXPS13 kernel: sd 11:0:0:0: [sdb] Attached SCSI disk
Nov 14 23:17:43 rongcuiXPS13 kernel: EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null)
Nov 14 23:17:43 rongcuiXPS13 udisksd[612]: Mounted /dev/sdb2 at /run/media/carl/ExtTmp on behalf of uid 1000
Nov 14 23:17:43 rongcuiXPS13 gvfs-udisks2-volume-monitor[693]: disc.c:350: error opening file BDMV/index.bdmv
Nov 14 23:17:43 rongcuiXPS13 gvfs-udisks2-volume-monitor[693]: disc.c:350: error opening file BDMV/BACKUP/index.bdmv
Nov 14 23:17:43 rongcuiXPS13 dbus-daemon[516]: Activating service name='org.gnome.Shell.HotplugSniffer'
Nov 14 23:17:43 rongcuiXPS13 dbus-daemon[516]: Successfully activated service 'org.gnome.Shell.HotplugSniffer'
Nov 14 23:17:43 rongcuiXPS13 ntfs-3g[10005]: Version 2015.3.14 external FUSE 29
Nov 14 23:17:43 rongcuiXPS13 ntfs-3g[10005]: Mounted /dev/sdb1 (Read-Write, label "CARL_SHARE", NTFS 3.1)
Nov 14 23:17:43 rongcuiXPS13 ntfs-3g[10005]: Cmdline options: rw,nodev,nosuid,uid=1000,gid=1000,uhelper=udisks2
Nov 14 23:17:43 rongcuiXPS13 ntfs-3g[10005]: Mount options: rw,nodev,nosuid,uhelper=udisks2,allow_other,nonempty,relatime,default_permissions,fsname=/dev/sdb1,blkdev,blksize=4096
Nov 14 23:17:43 rongcuiXPS13 ntfs-3g[10005]: Global ownership and permissions enforced, configuration type 7
Nov 14 23:17:43 rongcuiXPS13 udisksd[612]: Mounted /dev/sdb1 at /run/media/carl/CARL_SHARE on behalf of uid 1000
Nov 14 23:17:43 rongcuiXPS13 gvfs-udisks2-volume-monitor[693]: disc.c:350: error opening file BDMV/index.bdmv
Nov 14 23:17:43 rongcuiXPS13 gvfs-udisks2-volume-monitor[693]: disc.c:350: error opening file BDMV/BACKUP/index.bdmv
Nov 14 23:18:29 rongcuiXPS13 dbus-daemon[516]: Activating service name='org.gnome.Nautilus'
Nov 14 23:18:29 rongcuiXPS13 dbus-daemon[516]: Successfully activated service 'org.gnome.Nautilus'
Nov 14 23:18:29 rongcuiXPS13 dbus[435]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service'
Nov 14 23:18:29 rongcuiXPS13 systemd[1]: Starting Hostname Service...
Nov 14 23:18:29 rongcuiXPS13 dbus[435]: [system] Successfully activated service 'org.freedesktop.hostname1'
Nov 14 23:18:29 rongcuiXPS13 systemd[1]: Started Hostname Service.
Nov 14 23:18:45 rongcuiXPS13 systemd[1]: run-media-carl-ExtData.mount: Failed to run 'mount' task: No such file or directory
Nov 14 23:18:45 rongcuiXPS13 udisksd[612]: Cleaning up mount point /run/media/carl/CARL_SHARE (device 8:17 is not mounted)
Nov 14 23:18:45 rongcuiXPS13 systemd[1]: Failed to mount /run/media/carl/ExtData.
Nov 14 23:18:45 rongcuiXPS13 ntfs-3g[10005]: Unmounting /dev/sdb1 (CARL_SHARE)
Nov 14 23:18:45 rongcuiXPS13 udisksd[612]: Unmounted /dev/sdb1 on behalf of uid 1000
Nov 14 23:18:46 rongcuiXPS13 udisksd[612]: Cleaning up mount point /run/media/carl/ExtTmp (device 8:18 is not mounted)
Nov 14 23:18:46 rongcuiXPS13 udisksd[612]: Unmounted /dev/sdb2 on behalf of uid 1000
Nov 14 23:18:48 rongcuiXPS13 kernel: usb 2-2: USB disconnect, device number 7
Nov 14 23:18:48 rongcuiXPS13 colord[611]: /usr/lib/colord/colord-sane: error while loading shared libraries: libsane.so.1: cannot open shared object file: No such file or directory
Nov 14 23:18:48 rongcuiXPS13 colord[611]: /usr/lib/colord/colord-sane: error while loading shared libraries: libsane.so.1: cannot open shared object file: No such file or directory
Nov 14 23:18:48 rongcuiXPS13 colord[611]: /usr/lib/colord/colord-sane: error while loading shared libraries: libsane.so.1: cannot open shared object file: No such file or directory

Old Log (I think it is the part, I hand copied them)

Nov 13 16:15:52 rongcuiXPS13 kernel: ses 6:0:0:1: Attached Enclosure device
Nov 13 16:15:52 rongcuiXPS13 kernel: sd 6:0:0:0: [sdc] Attached SCSI disk
Nov 13 16:15:52 rongcuiXPS13 colord[625]: /usr/lib/colord/colord-sane: error while loading shared libraries: libsane.so.1: cannot open shared object file: No such file or directory
Nov 13 16:15:52 rongcuiXPS13 kernel: EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: (null)
Nov 13 16:15:52 rongcuiXPS13 udisksd[626]: Mounted /dev/sdc1 at /run/media/carl/ExtData on behalf of uid 1000

Steps to reproduce:

Plug in an External HDD
Open nautilus, then Other Locations
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 01 September 2016, 09:55 GMT
Reason for closing:  Fixed
Comment by st.binder (nium) - Monday, 16 November 2015, 22:12 GMT
same here, but only tested with encrypted external hard disks. Drives are not visible in Nautilus if connected to USB2 or USB3.
Comment by Luis Henrique Mello (lmello) - Tuesday, 17 November 2015, 17:42 GMT
Same thing here.

I noticed a problem with SD cards in Nautilus, so I filed a bug upstream https://bugzilla.gnome.org/show_bug.cgi?id=756782

They marked it as a duplicate of https://bugzilla.gnome.org/show_bug.cgi?id=756589

And they said the issue was fixed.


I have:

gtk3 3.18.4-1
nautilus 3.18.2-1

and a 64-bit system.
Comment by Luis Henrique Mello (lmello) - Tuesday, 17 November 2015, 17:50 GMT
gvfs was last updated in 2015-11-09.

The upstream bug was a fix on gtk3's code. On arch gtk3 was updated in 2015-12-09 and nautilus in 2015-13-09. Maybe recompiling gvfs will solve this issue.
Comment by st.binder (nium) - Tuesday, 17 November 2015, 18:14 GMT
recompiling gvfs indeed solves this issue!
Comment by Luis Henrique Mello (lmello) - Saturday, 21 November 2015, 08:12 GMT
with gtk3 3.18.5 all external drives are shown in the sidebar. Don't know about 'Other Locations' yet, I have a laptop and only one internal HD. Recompiling gvfs should do the trick tough, as @nium said.

Loading...