Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47068 - [firefox] liblgpllibs.so not found

Attached to Project: Arch Linux
Opened by Karoly Negyesi (chx) - Saturday, 14 November 2015, 21:03 GMT
Last edited by Evangelos Foutras (foutrelis) - Monday, 16 November 2015, 05:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Evangelos Foutras (foutrelis)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Firefox doesn't start, ldd /usr/lib/firefox/libxul.so|grep 'not found'reports liblgpllibs.so => not found. Added /etc/ld.so.conf.d/firefox.conf containing /usr/lib/firefox ran ldconfig, firefox runs.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Monday, 16 November 2015, 05:48 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Sunday, 15 November 2015, 17:42 GMT
Works fine for me, even though ldd doesn't find that lib. What errors do you get?
Comment by Karoly Negyesi (chx) - Sunday, 15 November 2015, 19:13 GMT
Well, at first it didn't start but that was probably because of a libvpx update I didn't do, I had two libraries missing, I fixed the first as described here then updated libvpx which made it start. Now, if ldd doesn't find that lib that's reason enough to implement the simple fix I suggested here, isn't it?
Comment by Doug Newgard (Scimmia) - Sunday, 15 November 2015, 19:21 GMT
If it doesn't cause any problems, not really.
Comment by Evangelos Foutras (foutrelis) - Monday, 16 November 2015, 05:48 GMT
Firefox dynamically loads libraries listed in /usr/lib/firefox/dependentlibs.list so this is a non-issue.

Loading...