Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47041 - [chromium] cannot build from ABS in a clean chroot

Attached to Project: Arch Linux
Opened by John (graysky) - Wednesday, 11 November 2015, 21:26 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 11 November 2015, 22:05 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

My build errors out about 1/3 of the way though. Complete build.log attached. Partial:

[5698/18580] CXX obj/components/cloud_devices/common/cloud_devices_common.printer_description.o
[5699/18580] CXX obj/third_party/webrtc/modules/video_coding/codecs/vp9/webrtc_vp9.vp9_frame_buffer_pool.o
[5700/18580] CXX obj/third_party/webrtc/modules/video_coding/codecs/vp9/webrtc_vp9.vp9_impl.o
FAILED: c++ -MMD -MF obj/third_party/webrtc/modules/video_coding/codecs/vp9/webrtc_vp9.vp9_impl.o.d -DV8_DEPRECATION_WARNINGS -DCLD_VERSION=2 -D_FILE_OFFSET_BITS=64 -DCHROMIUM_BUILD -DCR_CLANG_REVISION=245402-1 -DUI_COMPOSITOR_IMAGE_TRANSPORT -DUSE_AURA=1 -DUSE_ASH=1 -DUSE_PANGO=1 -DUSE_CAIRO=1 -DUSE_DEFAULT_RENDER_THEME=1 -DUSE_LIBJPEG_TURBO=1 -DUSE_X11=1 -DUSE_CLIPBOARD_AURAX11=1 -DENABLE_ONE_CLICK_SIGNIN -DENABLE_PRE_SYNC_BACKUP -DENABLE_WEBRTC=1 -DENABLE_MEDIA_ROUTER=1 -DUSE_PROPRIETARY_CODECS -DENABLE_PEPPER_CDMS -DENABLE_CONFIGURATION_POLICY -DENABLE_NOTIFICATIONS -DENABLE_HIDPI=1 -DENABLE_TOPCHROME_MD=1 -DUSE_UDEV -DDONT_EMBED_BUILD_METADATA -DTRACING_IS_OFFICIAL_BUILD=1 -DENABLE_TASK_MANAGER=1 -DENABLE_EXTENSIONS=1 -DENABLE_PLUGINS=1 -DENABLE_SESSION_SERVICE=1 -DENABLE_THEMES=1 -DENABLE_AUTOFILL_DIALOG=1 -DENABLE_BACKGROUND=1 -DENABLE_GOOGLE_NOW=1 -DENABLE_PRINTING=1 -DENABLE_BASIC_PRINTING=1 -DENABLE_PRINT_PREVIEW=1 -DENABLE_SPELLCHECK=1 -DENABLE_CAPTIVE_PORTAL_DETECTION=1 -DENABLE_APP_LIST=1 -DENABLE_SETTINGS_APP=1 -DENABLE_SUPERVISED_USERS=1 -DENABLE_MDNS=1 -DENABLE_SERVICE_DISCOVERY=1 -DENABLE_HANGOUT_SERVICES_EXTENSION=1 -DV8_USE_EXTERNAL_STARTUP_DATA -DFULL_SAFE_BROWSING -DSAFE_BROWSING_CSD -DSAFE_BROWSING_DB_LOCAL -DSAFE_BROWSING_SERVICE -DWEBRTC_RESTRICT_LOGGING -DEXPAT_RELATIVE_PATH -DWEBRTC_CHROMIUM_BUILD -DLOGGING_INSIDE_WEBRTC -DWEBRTC_POSIX -DWEBRTC_LINUX -DUSE_LIBPCI=1 -DUSE_OPENSSL=1 -DUSE_GLIB=1 -DUSE_NSS_CERTS=1 -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -DNDEBUG -DNVALGRIND -DDYNAMIC_ANNOTATIONS_ENABLED=0 -D_FORTIFY_SOURCE=2 -Igen/shim_headers/libvpx/target -Igen -I../.. -I../../third_party/webrtc/overrides -I../../third_party -I../../third_party/webrtc/common_video/interface -I../../third_party/webrtc/common_video/libyuv/include -I../../third_party/libyuv/include -I../../third_party/libyuv -fstack-protector --param=ssp-buffer-size=4 -pthread -fno-strict-aliasing -Wall -Wno-unused-parameter -Wno-missing-field-initializers -fvisibility=hidden -pipe -fPIC -Wno-unused-local-typedefs -m64 -march=x86-64 -O2 -fno-ident -fdata-sections -ffunction-sections -funwind-tables -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -D_FORTIFY_SOURCE=2 -fno-exceptions -fno-rtti -fno-threadsafe-statics -fvisibility-inlines-hidden -Wsign-compare -std=gnu++11 -Wno-narrowing -Wno-literal-suffix -c ../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc -o obj/third_party/webrtc/modules/video_coding/codecs/vp9/webrtc_vp9.vp9_impl.o
In file included from ../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.cc:12:0:
../../third_party/webrtc/modules/video_coding/codecs/vp9/vp9_impl.h:18:29: fatal error: vpx/svc_context.h: No such file or directory
compilation terminated.
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
Aborting...

Additional info:
* package version(s) chromium-46.0.2490.86-1

Steps to reproduce:
1) Create a clean chroot
2) Enable multilib
3) Build... error should occur at step 5700.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 11 November 2015, 22:05 GMT
Reason for closing:  Works for me
Additional comments about closing:  Your chroot needs to have [testing] enabled, since you're building Chromium from testing. (In particular, libvpx 1.5.0-2 is required.)

Loading...