Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#47013 - [qt5-base] Missing dependency libxkbcommon-x11 ?

Attached to Project: Arch Linux
Opened by Jean-Baptiste Lamy (jiba) - Monday, 09 November 2015, 13:24 GMT
Last edited by Antonio Rojas (arojas) - Monday, 09 November 2015, 14:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Qt applications crash with the following error message :

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.


Installing the "libxkbcommon-x11" package fixed this problem. Perhaps it should be added as a dependency to Qt ?

Additional info:
* qt5-base-5.5.1-3
* libxkbcommon-x11-0.5.0-1-i686
* tested on a Virtual Box with ArchLinux freshly updated


Steps to reproduce:

Run a Qt 5 application with libxkbcommon-x11 package not installed. (I tested with a PyQt 5 app but the problem does not seem to be Python-related).
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 09 November 2015, 14:10 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#40468 

Loading...