Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46994 - [xf86-input-evdev] Logitech G600 Mouse bug with xorg-server 1.17.4-* and xf86-input-evdev 2.10.0-1

Attached to Project: Arch Linux
Opened by Gabriel Cavallo (gcavallo) - Saturday, 07 November 2015, 11:27 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 04 January 2016, 11:51 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

(This is my first bug report here sorry if mistakes are made)

Logitech G600 Mouse buttons are not registered properly after xorg upgrade. The mouse cursor is dragged approximately 50% to to left when using the left-click (making the cursor unusable). Bug is on all WM/DE.

---

Steps to reproduce:

Pacman -Syyu

[2015-11-05 22:33] [ALPM] upgraded xf86-input-evdev (2.9.2-1 -> 2.10.0-1)
[2015-11-05 22:33] [ALPM] upgraded xorg-server-common (1.17.4-1 -> 1.17.4-2)
[2015-11-05 22:33] [ALPM] upgraded xorg-server (1.17.4-1 -> 1.17.4-2)

Restart X

(G600 is bugged at that that point)

Sadly all my xorg logs are from after the problem was solved..

---

Steps to fix:

Stop X

sudo mv /usr/share/X11/xorg.conf.d/10-evdev.conf /usr/share/X11/xorg.conf.d/10-evdev.conf.1.17.4-2

cd /var/cache/pacman/pkg
sudo pacman -U xorg-server-1.17.3-1-x86_64.pkg.tar.xz xorg-server-common-1.17.3-1-x86_64.pkg.tar.xz
sudo pacman -U xf86-input-evdev-2.9.2-1-x86_64.pkg.tar.xz

Start X
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 04 January 2016, 11:51 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.10.0-3
Comment by Andreas Radke (AndyRTR) - Saturday, 07 November 2015, 11:55 GMT
Not sure if your device will need a different configuration now. But sounds more like an upstream bug.
Check Changelog and look/file an upstream bug.
Comment by Chris Harper (charper) - Sunday, 08 November 2015, 09:53 GMT
I fixed this with the following changes to xorg.conf:

Section "ServerFlags"
Option "AllowEmptyInput" "False"
Option "AutoAddDevices" "False"
Option "AutoEnableDevices" "False"
EndSection

Section "InputDevice"

Identifier "Evdev Mouse"
Driver "evdev"
# Follow Arch wiki https://wiki.archlinux.org/index.php/All_Mouse_Buttons_Working to find ID
Option "Device" "/dev/input/by-id/usb-Logitech_Gaming_Mouse_G600_A7E7279BB98D0012-event-mouse"
EndSection

Comment by Gabriel Cavallo (gcavallo) - Monday, 09 November 2015, 16:21 GMT
The ID hash is different for me: /dev/input/by-id/usb-Logitech_Gaming_Mouse_G600_CA62604B87090017-event-mouse

Using those xorg settings I'm unable to use any input device (need to hard-reset). Had to downgrade again...
Comment by Chris Harper (charper) - Tuesday, 10 November 2015, 06:58 GMT
The server flags may have stopped the keyboard from loading but I'd of thought the mouse would still load.
Comment by Ben (Idiotgenius) - Wednesday, 11 November 2015, 20:13 GMT
I'm having the same bug, behaviour is a little different though. Instead of going 50% to the left, it goes to the very left edge of the screen. I can confirm it happens across all DEs. I tried moving from the proprietary Nvidia driver to the Nouveau driver and it still affected me. Multimonitor always brings it to the very left monitor edge.

I don't know how to get logs, but I just plugged another mouse in for now, so if you want some, just tell me how and I'll send them!
Comment by Gabriel Cavallo (gcavallo) - Wednesday, 11 November 2015, 20:18 GMT
Yeah it pretty much moves completely to the left, depends on that button is pressed.

I've opened a ticket at https://bugs.freedesktop.org/show_bug.cgi?id=92856

A patch is available there if you wish to compile it.
Comment by Chris Harper (charper) - Thursday, 12 November 2015, 07:47 GMT
I'm confused why mine is working with the above changes to xorg.conf . Seems like it shouldn't without the patch on the other list. Wonder if its a firmware difference in the mice.

xf86-input-evdev 2.10.0-1
xorg-server 1.17.4-2
xorg-server-common 1.17.4-2
Comment by Gabriel Cavallo (gcavallo) - Thursday, 12 November 2015, 14:35 GMT
Are you also using the included 10-evdev.conf besides those changes? At what priority are you loading them?
Comment by Chris Harper (charper) - Thursday, 12 November 2015, 15:47 GMT
Other than the changes above and those set my nvidia-settings it is as standard.

I load everything through startx/.xinitrc(standard other than some other applications starting up) into i3, no display manager.
Comment by Gabriel Cavallo (gcavallo) - Wednesday, 18 November 2015, 23:32 GMT
Installing "xf86-input-libinput" also fixes the issue.

My understanding is that it's a new input driver loaded with a higher priority if installed.

Loading...