Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46968 - [linux] Display is broken after upgrading to linux kernel 4.3.

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Wednesday, 04 November 2015, 16:07 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 24 December 2015, 07:30 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Simple bug to reproduce.

If you use an Intel chipset with linux 4.3, display is completely busted. I saw that on my asus eeePC with an intel video chipset and archlinux testing on it.

Additional info:
linux 4.3-1
1:2.99.917+478+gdf72bc5-2

Steps to reproduce:

See details.

This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 24 December 2015, 07:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.3.3-2
Comment by Frederic Bezies (fredbezies) - Wednesday, 04 November 2015, 16:53 GMT
More infos.

It seems to break display with this chipset :

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

I attached error log. Only workaround on my eeePC was to "downgrade to linux 4.2.5.

Comment by Daniel Hahler (blueyed) - Thursday, 12 November 2015, 00:40 GMT
Does not affect any/all Intel chipsets. It works on a Lenovo X250 with:

00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
Comment by Frederic Bezies (fredbezies) - Thursday, 12 November 2015, 15:17 GMT
Display is broken on my old eeePC with intel 945 chipset. But on my Toshiba, which is also using intel chipset, no problem.

My laptop is using :

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

So, only breaking old chipsets like intel 945 one ?
Comment by Eli Schwartz (eschwartz) - Wednesday, 18 November 2015, 04:16 GMT
Same problem here on an old Dell Inspiron B130 with aur/linux-ck and testing/linux.


00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
Comment by txtsd (txtsd) - Wednesday, 18 November 2015, 09:44 GMT
Works fine on my ancient GM965

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)
Comment by John (graysky) - Wednesday, 18 November 2015, 11:40 GMT
Using linux from ABS (4.3-1 with a few custom settings in the .config) works fine on the following hardware as does the corresponding linux-ck (4.3-1). Note I do not have [testing] enabled:

*Broadwell i7-4790K that uses HD Graphics 4600
*Haswell i3-4130T that uses HD Graphics 4400
*Ivy i7-3770K that uses HD Graphics 4000

@Frederic - Did you open a report upstream?
Comment by Frederic Bezies (fredbezies) - Wednesday, 18 November 2015, 11:43 GMT
I didn't report it. I will try to see if it is a known bug or not.
Comment by John (graysky) - Wednesday, 18 November 2015, 11:49 GMT
My recommendation is that you open one up against the "Video(DRI - Intel)" at https://bugzilla.kernel.org/enter_bug.cgi?product=Drivers

In the past, Chris has been very swift and accurate in diagnosing and fixing.
Comment by Frederic Bezies (fredbezies) - Wednesday, 18 November 2015, 11:58 GMT
https://bugzilla.kernel.org/show_bug.cgi?id=108141

And after googling "drivers/gpu/drm/drm_atomic_helper.c:674" I found this :

https://lkml.org/lkml/2015/11/12/467
Comment by Frederic Bezies (fredbezies) - Wednesday, 18 November 2015, 13:22 GMT
Looks like my invalid bug (I choose the wrong component) was a duplicate of this one : https://bugs.freedesktop.org/show_bug.cgi?id=92655
Comment by Eli Schwartz (eschwartz) - Wednesday, 18 November 2015, 21:42 GMT
From the freedesktop.org bug (comment #4), this patch fixed linux-ck for me: http://lists.freedesktop.org/archives/intel-gfx/2015-November/079894.html
Comment by Frederic Bezies (fredbezies) - Wednesday, 18 November 2015, 21:43 GMT
Thanks for the feedback. I hope it could be integrated for kernel 4.3.1 :D
Comment by Larry Johnson (keepitsimpleengineer) - Tuesday, 24 November 2015, 15:53 GMT
I uas a Lenovo S12 (Intel) with:
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

With linux-4.3-1 and linux-ck-4.3.1 running archlinux i686 I experience this bug.

However, with linux-ck-4.3.1 running manjaro i686 there is no such bug.

UPDATE: After reinstalling manjaro (12/20) for reasons unrelated to this bug, I now find the 4.3 kernel unusable.

UPDATE #2: graysky's 2015/12/24 update to linux-ck 4.3.3-2 was installed and now works. (Lenovo Ideapad S12)
Comment by Frederic Bezies (fredbezies) - Tuesday, 24 November 2015, 16:04 GMT
Smells like there is a different .config file used for Manjaro linux kernel package.
Comment by Larry Johnson (keepitsimpleengineer) - Tuesday, 24 November 2015, 18:55 GMT
Both 4.3.2. -ck packages came from graysky's repo-ck and likely on the same day... .. .
Comment by So As (Archilious) - Thursday, 03 December 2015, 23:01 GMT
On AMD E450 with Radeon HD6320 running all 'testing' Arch Linux x86_64 including kernel 4.3.0-1, no such bugs, running smooth. Everything's fine.

Comment by So As (Archilious) - Sunday, 06 December 2015, 05:20 GMT
On Sony Vaio with Intel(R) Core(TM) i3-2310M CPU :
0:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
4.3.0-1-ARCH #1 SMP PREEMPT Mon Nov 2 16:52:35 CET 2015 x86_64 GNU/Linux

No display problems.
Comment by Frederic Bezies (fredbezies) - Thursday, 10 December 2015, 13:13 GMT
Linux 4.3.1-1 is still breaking display on old intel chipset. Could it be possible to "backport" patch proposed in kernel bug report ? https://bugs.freedesktop.org/show_bug.cgi?id=92655 -> https://bugs.freedesktop.org/attachment.cgi?id=119541

Thanks for your answer.
Comment by Eli Schwartz (eschwartz) - Thursday, 10 December 2015, 16:03 GMT Comment by Frederic Bezies (fredbezies) - Tuesday, 15 December 2015, 14:59 GMT
Too bad kernel 4.3.3-1 is still busted. Maybe in 4.3.4 with a little luck ?
Comment by Frederic Bezies (fredbezies) - Tuesday, 15 December 2015, 15:02 GMT
Just wondering : could it be possible to move this kernel to core and ask users with old Intel Chipset (like the 945GSE one) to switch to linux lts kernel ? Or is there any old blocker to move this kernel in core ?
Comment by Eli Schwartz (eschwartz) - Tuesday, 15 December 2015, 18:23 GMT
I thought this was the blocker. (Well, I don't know, there could be more.)

Deliberately releasing a buggy kernel to core and suggesting affected people use linux-lts seems to be defeating the purpose of *having* a testing repo.

...

The fix appears to be in linux-next.
Comment by Frederic Bezies (fredbezies) - Tuesday, 15 December 2015, 18:38 GMT
I understand this is against the purpose of testing repositories. In linux-next ? Let's hope it will be in next release and that next release won't be in a month like it takes for linux 4.3.1 patch.

I feel a little guilty for having filled such a blocker, even if kernel developers are also guilty here.
Comment by cfr (cfr42) - Wednesday, 23 December 2015, 22:10 GMT
As a user of the stable repo, I am more than happy if people using testing file bugs which block the release of buggy kernels to core! I always thought that was the point....

[I'm only here because I wanted to be sure my updates hadn't gotten messed up somehow since I realised it was a while since I'd had a new kernel. I am pleased to discover that there is a perfectly good reason for this.]

Loading...