Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#46942 - [systemd] pxe booting install media fails to rename eth0 & start dhcpcd

Attached to Project: Release Engineering
Opened by Ian Kelling (IanKelling) - Sunday, 01 November 2015, 23:48 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Tuesday, 03 November 2015, 23:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Steps to reproduce:
1. Boot installation media using pxe
2. journalctl

https://wiki.archlinux.org/index.php/PXE, in my case I used nfs.

Nov 01 16:36:30 archiso systemd-udevd[345]: Error changing net interface name 'eth0' to 'enp6s0': Device or resource busy
Nov 01 16:36:30 archiso systemd-udevd[345]: could not rename interface '2' from 'eth0' to 'enp6s0': Device or resource busy

...

Nov 01 16:36:31 archiso systemd[1]: Starting dhcpcd on enp6s0...
Nov 01 16:36:31 archiso systemd[1]: Started Entropy Harvesting Daemon.
Nov 01 16:36:31 archiso systemd[1]: Starting Login Service...
Nov 01 16:36:31 archiso systemd[1]: Started D-Bus System Message Bus.
Nov 01 16:36:31 archiso dhcpcd[393]: enp6s0: interface not found or invalid
Nov 01 16:36:31 archiso dhcpcd[393]: dhcpcd exited
Nov 01 16:36:31 archiso dbus[396]: [system] Successfully activated service 'org.freedesktop.systemd1'
Nov 01 16:36:31 archiso systemd[1]: Starting Initializes Pacman keyring...
Nov 01 16:36:31 archiso systemd[1]: Starting Permit User Sessions...
Nov 01 16:36:31 archiso systemd[1]: dhcpcd@enp6s0.service: Control process exited, code=exited status=1
Nov 01 16:36:31 archiso systemd[1]: Failed to start dhcpcd on enp6s0.
Nov 01 16:36:31 archiso systemd[1]: dhcpcd@enp6s0.service: Unit entered failed state.
Nov 01 16:36:31 archiso systemd[1]: dhcpcd@enp6s0.service: Failed with result 'exit-code'.



I assume 'Device or resource busy' is because we are already using eth0 for network booting. Then later dhcpcd expects the rename to have happened and fails. If you ignore this and run dhcpcd yourself, you may also not expect that eth0 changes to something like enp6s0 after installing.


Tested on 2 x64 machines, 1 desktop, 1 is a lenovo thinkpad x200.
Tested 2 isos:
archlinux-2015.11.01-dual.iso
archlinux-2015.10.01-dual.iso
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Tuesday, 03 November 2015, 23:01 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#36749
Comment by Ian Kelling (IanKelling) - Sunday, 01 November 2015, 23:51 GMT
I accidentally filed this with Category 'Packages: Extra', which seems wrong.

I don't see a way to change it though. Feel free to update it.
Comment by Ian Kelling (IanKelling) - Monday, 02 November 2015, 02:19 GMT
This is a duplicate of FS#36749. I'm moving the relevant info to a comment on that bug.

Loading...