Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46902 - [linux] HP Laptop -- No Video Output

Attached to Project: Arch Linux
Opened by M.Reynolds (TheChickenMan) - Wednesday, 28 October 2015, 19:09 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 15 December 2015, 13:03 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:

linux-4.2.4-1-i686
linux-4.2.5-1-i686

Steps to reproduce:

Installing linux package versions over 4.2.3 cause video output not to work
on HP NC6400 laptops. The computer appears to run as everything is accessible via
ssh but there is a black screen and no video output after the bootloader.

[url]https://bbs.archlinux.org/viewtopic.php?id=204421[/url]
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 15 December 2015, 13:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.3.x
Comment by Karl-Philipp Wulfert (animungo) - Thursday, 29 October 2015, 14:04 GMT
I have the same problem on a Thinkpad Z61m since upgrading to linux-4.2.4-1.

I downgraded mesa packages and the linux package but now I got only a scrambled image when starting up X.

Using "nomodeset" as boot parameter fixes the scrambled image and also the black screen while booting.

Edit: Sorry, I forgot to mention that I have the x86_64 version of the kernel.

Update: Just upgraded to linux-4.2.5-1, same same... Problem persists.
Comment by Louis (bellerofonte) - Friday, 30 October 2015, 16:32 GMT
Same problem on DELL notebook (ATI card with driver open)
To solve the problem I had to reinstall (downgraded) : linux packages 4.2.3-1 , xorg-server-1.17.2-4 and xorg-server-common-1.17.2-4

update
i have upgraded xorg (latest package) and, with old kernel (4.2.3-1) ,the system is ok.
The problem is only in the kernel
Comment by Jens Adam (byte) - Saturday, 31 October 2015, 01:58 GMT
Same here. Downgrade to 4.2.3 fixes it, latest -lts also won't display anything.
Seems to be some radeon KMS regression.
Comment by Jens Adam (byte) - Saturday, 31 October 2015, 07:07 GMT
Reverting https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/commit/drivers/gpu/drm/radeon?id=5a633828b4b2bef343826afcb0a70770c4911c55 fixes the issue (black screen / interrupted boot upon Radeon KMS initialization) for me.
Comment by Jens Adam (byte) - Saturday, 31 October 2015, 23:42 GMT
... and one last information: I had no problem with the default Arch 4.2.5 kernel on my desktop (x86_64, ATI RV620).
Laptop specs: IBM T60p, i686, ATI RV530/M56 GL [Mobility FireGL V5200]
Comment by Peter Hardman (shetland_breeder) - Sunday, 01 November 2015, 09:13 GMT
Same problem on my Thinkpad T60 (ATI x1300) with 4.2.5- x86_64. Downgrade to 4.2.3-1 (or setting 'nomodeset') resolves the black screen.
Comment by Martin Gignac (techstone) - Monday, 02 November 2015, 18:30 GMT
Same comment as everyone. I have a Dell Latitude D531 with an ATI Radeon card and starting from 4.2.4 (x86_64) I get a blank screen. "nomodeset" works around the issue but SLiM (and probably X) no longer work. Reverting back to a kernel pre 4.2.4 resolves the issue
Comment by lmat (lmat) - Monday, 09 November 2015, 18:13 GMT
Same here. Lenovo Thinkpad T60 ATI x1400. X doesn't work with nomodeset in use (which I assume I could correct). I see that the troublesome commit has been identified which is excellent. I look forward to seeing this regression fixed! I assume 686 is still an high priority? Thanks for the advice, others, and especially Namarrgon in IRC!

Does a kernel bug exist for this?
Comment by dakaujunk (dakaujunk) - Saturday, 14 November 2015, 21:30 GMT
Faced the same issue on Thinkpad T60. A temporary resolution (needs every boot) that I found to work was to turn on DPMS after booting. Just commented in https://bbs.archlinux.org/viewtopic.php?id=204421. Run the following command (sudo or su, suit yourself), after booting and launching a terminal:

sudo vbetool dpms on

Hope this helps.
Comment by Christian Stadegaart (c.stadegaart) - Saturday, 12 December 2015, 23:21 GMT
+1 on HP Compaq 6820s laptop after installing kernel 4.5.2-1 (x86_64). Reverted to 4.1.6-1.
Comment by Jens Adam (byte) - Monday, 14 December 2015, 12:15 GMT
FYI: The issue is fixed since kernel 4.3 (should hopefully arrive in [core] soon)

Loading...