Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46860 - [fbterm] Insert mode is broken in fbterm (patch provided)

Attached to Project: Community Packages
Opened by Yuri I. Kornilov (katatsumuri) - Saturday, 24 October 2015, 15:18 GMT
Last edited by Balló György (City-busz) - Wednesday, 24 January 2018, 07:06 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Insert mode is broken in fbterm ('echo -e "\033[4h"' causes Segmentation Fault).

This bug causes crashes with some programs. For example, the original vi (default vi variant in Arch Linux) produces segfault each time when inserting at the beginning of the line.

The problem is in using the unsigned variable for storing negative value in fbterm code. It seems that fbterm is not maintained upstream anymore, so I suggest my patch here (see attachment).

Additional info:
* package version 1.7.0-6
This task depends upon

Closed by  Balló György (City-busz)
Wednesday, 24 January 2018, 07:06 GMT
Reason for closing:  Won't fix
Comment by Balló György (City-busz) - Wednesday, 24 January 2018, 07:06 GMT
fbterm is no longer available in the official repositories.

Loading...