Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46836 - [w3m] does not display images in terminals with a 32 bits color depth

Attached to Project: Arch Linux
Opened by Maurizio D'Addona (mauritiusdadd) - Friday, 23 October 2015, 08:40 GMT
Last edited by Gaetan Bisson (vesath) - Friday, 23 October 2015, 21:07 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

It seems that w3m is not able to display images in terminals wich have a color depth of 32 bits. A patch to fix this issue is available here [1].
I know it is an upstream bug, but the upstream seems to be dead and all the pactches proposed in the last couple of years were simply ignored.

Additional info:
* see the comment on the AUR package I maintain: https://aur.archlinux.org/packages/w3m-mouse/

Steps to reproduce:
* run w3m in a terminal wich support a color depth of 32 bits
- for urxvt add the string URxvt.depth:32 to the file Xresources, and reload it using xrdb
- start a new instance of urxvt
- run w3m in the new instance of urxvt
* Try to display some images (for example search something in google images)
This task depends upon

Closed by  Gaetan Bisson (vesath)
Friday, 23 October 2015, 21:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  w3m-0.5.3-10 in [extra]
Comment by Gaetan Bisson (vesath) - Friday, 23 October 2015, 17:23 GMT
The link to the patch seems to be missing from your report. Could you also link to some upstream discussion where the patch originates or has been approved? Thanks.
Comment by Maurizio D'Addona (mauritiusdadd) - Friday, 23 October 2015, 18:27 GMT
I'm very sorry, somehow I forgot to add the link :/

Here there is the patch: https://gist.github.com/BwackNinja/60a344730170f9ce2163
And this is the discussion on github: https://github.com/hut/ranger/issues/86

The discussion itself is on the github page of ranger, and the patch has never been sent to w3m upstrem but as I've said the upstream seems to be dead

--edit:
I've opened a ticket also on the sourceforge page of w3m... there's no harm in trying: https://sourceforge.net/p/w3m/patches/72/

Loading...