Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46817 - [thunar] crash on file drag and drop

Attached to Project: Arch Linux
Opened by IMBJR (IMBJR) - Wednesday, 21 October 2015, 17:48 GMT
Last edited by Evangelos Foutras (foutrelis) - Monday, 05 June 2017, 05:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 16
Private No

Details

Description: Dragging and dropping an image file from the desktop into a Thunar session leads to segfault

Additional info:
* Thunar 1.6.10-2

.xsession-errors reports:

(process:16434): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(Thunar:15864): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed

(Thunar:15864): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

(Thunar:16674): GLib-GObject-CRITICAL **: g_object_set_qdata: assertion 'G_IS_OBJECT (object)' failed

(Thunar:16674): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
*** Error in `/usr/bin/Thunar': double free or corruption (!prev): 0x0000000001597440 ***
======= Backtrace: =========
/usr/lib/libc.so.6(+0x72055)[0x7f14f6967055]
/usr/lib/libc.so.6(+0x779a6)[0x7f14f696c9a6]
/usr/lib/libc.so.6(+0x7818e)[0x7f14f696d18e]
/usr/bin/Thunar[0x4314fb]
/usr/bin/Thunar[0x4326ab]
/usr/bin/Thunar[0x432753]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x15a)[0x7f14f6effc7a]
/usr/lib/libglib-2.0.so.0(+0x4a020)[0x7f14f6f00020]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0xc2)[0x7f14f6f00342]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb7)[0x7f14f8ddc467]
/usr/bin/Thunar[0x41ed09]
/usr/lib/libc.so.6(__libc_start_main+0xf0)[0x7f14f6915610]
/usr/bin/Thunar[0x41ee29]

Steps to reproduce:
Dragging an image file (PNG and XBM files were used) from the XFCE desktop into a Thunar session showing the user's Pictures directory causes the segfault.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Monday, 05 June 2017, 05:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be completely fixed in thunar 1.6.11-2.
Comment by Evangelos Foutras (foutrelis) - Thursday, 22 October 2015, 04:35 GMT
Is this always reproducible on the first try? Might be a duplicate of  FS#46657 .

Edit: Found a Debian report that links the bug to glib 2.46, which is similar to the report I've filed upstream. [1]

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=800723#25
Comment by IMBJR (IMBJR) - Thursday, 22 October 2015, 15:52 GMT
This is reproducible. Every time I drag an image from the desktop into Thunar ... poof! This time I tried a JPeg.

However, this was not happening in a VM I have at work. It's a similar set up with XFCE, but it's not using the LTS kernel and its under VMWare.
Comment by IMBJR (IMBJR) - Wednesday, 16 December 2015, 17:36 GMT
Just had this happen again.

BTW the previous message mentions LTS - I'm no longer using that.
Comment by IMBJR (IMBJR) - Thursday, 17 December 2015, 17:49 GMT
Oof. Now I'm getting random crashes on renaming .m4a files. Thunar merely reports at the command line:

Segmentation fault (core dumped)

I'm running a strace on thunar, but it's decided to no longer crash.
Comment by Thomas (radioactiveman) - Monday, 21 December 2015, 18:57 GMT
Please backport this patch [1], it may help.

[1] http://git.xfce.org/xfce/thunar/commit/?id=029012f4
Comment by Evangelos Foutras (foutrelis) - Monday, 21 December 2015, 19:20 GMT
I have tried that patch and it does not help.

Edit: I mean it doesn't fix the crashes when renaming files ( FS#46657 ); I haven't had any crashes when using drag-n-drop so I can't comment on that.
Comment by Thomas (radioactiveman) - Monday, 21 December 2015, 19:36 GMT
I think it would not hurt adding it anyway. It is an official patch and fixes a crash.
Comment by IMBJR (IMBJR) - Tuesday, 22 December 2015, 17:13 GMT
The patch does not resolve the drag-and-drop crash.
Comment by Pablo Lezaeta (Jristz) - Saturday, 14 May 2016, 15:32 GMT
AMD 6510 using radeon driver and I can reproduce the issue aroun half the times I drag, I tried a torrent file and it crash the 2,4 and 5 time I tried it.

but I noticed that disabling rendering-fancy-stuff in xfce still got the same result but a little less often.
Comment by John Lindgren (jlindgren) - Sunday, 17 July 2016, 04:20 GMT
The drag-and-drop crash (which is distinct from the renaming crash,  FS#46657 ) is still present in upstream Git master.

Here is a fix that works for me:
https://github.com/jlindgren90/thunar/commit/e2d169d0c67d07f78b87509f798c97b004afdba4

Please consider including this patch in the Arch Linux package. No XFCE developer has made any comment on the upstream bug since February, so waiting for an upstream fix in this case may not be a good plan.
Comment by indianahorst (indianahorst) - Wednesday, 20 July 2016, 19:47 GMT
John, with Git master you mean thunar-git 1.6.10.r140.g6b51ff3-1?

This version still crashes sometimes when renaming a file.
Comment by Silvio Knizek (killermoehre) - Thursday, 06 October 2016, 13:33 GMT
Hey Evangelos,

maybe you want to add the patches from https://bugzilla.xfce.org/show_bug.cgi?id=12264 ?

BR
Silvio

Loading...