Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46755 - [lightdm] Sets GDM_LANG variable but not LANG

Attached to Project: Arch Linux
Opened by sb56637 (sb56637) - Friday, 16 October 2015, 18:20 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 17 October 2015, 14:12 GMT
Task Type Bug Report
Category Upstream Bugs
Status Assigned
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

I use two locales on my system, en_US.UTF-8 and en_ES.UTF8. I like to be able to switch between them for different users at the LightDM login screen so that the Cinnamon desktop and applications are displayed in the locale that the user chooses. The problem is that LightDM sets the wrong variable. If I select the en_ES.UTF8 locale in LightDM, after logging in my environment variables look like this:

$ env | grep LANG
LANG=en_US.UTF-8
GDM_LANG=es_ES.utf8

The en_US.UTF8 comes from my /etc/locale.conf, but LightDM should override this if I select something else.

I don't know if any other desktops use GDM_LANG, but most things need the LANG variable to be properly set.

This seems to be fixed upstream, but I don't know if those are Ubuntu-specific patches or what:
https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/1502921
https://bugs.launchpad.net/lightdm/+bug/1019314

Thanks.
This task depends upon

Comment by sb56637 (sb56637) - Saturday, 17 October 2015, 18:25 GMT
Thanks for assigning this bug. I just noticed a mistake in my original report:

> If I select the en_ES.UTF8 locale in LightDM ...

... should say "If I select the **es_ES.UTF8** locale in LightDM ..."
Comment by Maxime Gauduin (Alucryd) - Sunday, 07 February 2016, 09:41 GMT
Do you have AccountsService installed? It seems to set those correctly here, but only on the second login. The first time I change the locale via lightdm and log in I get the old one. I need to restart lightdm and log in again to get the new locale.
Comment by Jan Hradek (jan.hradek) - Saturday, 04 June 2016, 10:46 GMT
I have the same problem as Maxime.
I have AccountsService installed.
I use lightdm-gtk-greeter, cinnamon and lxde.
I have not touched any config at all except /etc/locale.gen, i.e. no bash, no cinnamon, no Xorg, no lxde, no lightdm all are used with the default config.

I know about https://wiki.archlinux.org/index.php/LightDM#Wrong_locale_displayed - I know that there is the /etc/environment config, but all it does is freezing the locale to whatever is in there.

The locale is always one session late, like:
select X -> You get something, logout,
select Y -> you get X, logout,
select Y -> you get Y, logout,
select X -> you get Y, logout,
select Y -> X, ....

Loading...