Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46724 - [mutter] 3.18.0-1 segfaults

Attached to Project: Arch Linux
Opened by brent saner (sanerb) - Thursday, 15 October 2015, 02:23 GMT
Last edited by Jan de Groot (JGC) - Thursday, 15 October 2015, 08:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When trying to start X (GDM, Xorg, etc.), the machine simply seems to hang- switching TTYs allows login, but X never loads (whether started via a DE/login manager or whether even started by startx/xinit/Xorg binary).

Additional info:

dmesg output:

[ 714.675214] gnome-shell[2468]: segfault at 14 ip 00007fe0812df1f5 sp 00007ffce196d5d0 error 4 in libmutter.so.0.0.0[7fe08129b000+fc000]

I've already tried reinstalling mutter (and gnome-shell) to no effect, and not seeing any drive corruption, so it doesn't seem to be the case of either.

This is on a system using nvidia-beta-dkms, with both standard kernel commandline and nomodeset (either makes no difference).
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 15 October 2015, 08:19 GMT
Reason for closing:  Not a bug
Comment by brent saner (sanerb) - Thursday, 15 October 2015, 05:19 GMT
...false alarm. seems this was due to nvidia-beta-dkms not including the (new) nvidia-modeset kernel module. requesting closure.

Loading...