Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#46721 - [gvfs] Using new gnome 3.18 can't mount any network shares via GVFS

Attached to Project: Arch Linux
Opened by Oscar Garcia (ogarcia) - Wednesday, 14 October 2015, 19:00 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 17 January 2016, 16:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 19
Private No

Details

Description:
Using new gnome 3.18 can't mount any network shares via GVFS. Google Drive and Owncloud also are not working.

None mounted in /run/user/$UID/gvfs

Additional info:
gvfs 1.26.1-3
gvfs-goa 1.26.1-3
gvfs-google 1.26.1-3
gvfs-mtp 1.26.1-3
gvfs-smb 1.26.1-3

nautilus 3.18.0-1

More info in forums:
https://bbs.archlinux.org/viewtopic.php?pid=1570511
https://bbs.archlinux.org/viewtopic.php?id=203791

Steps to reproduce:
Upgrade to latest gnome and try to open any file form network share.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 17 January 2016, 16:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  dbus 1.10.0-4
Comment by Frank Phillips (fphillips) - Wednesday, 14 October 2015, 22:38 GMT
How does root get permission denied?

[root@viron ~]# ls -ld /run/user/1000/*
ls: cannot access /run/user/1000/gvfs: Permission denied
srw-rw-rw- 1 fp users 0 Oct 13 17:59 /run/user/1000/bus
drwx------ 2 fp users 60 Oct 13 23:12 /run/user/1000/dconf
drwx------ 2 fp users 60 Oct 13 17:59 /run/user/1000/gnome
drwx------ 3 fp users 60 Oct 13 17:59 /run/user/1000/gnome-shell
drwx------ 2 fp users 40 Oct 13 17:59 /run/user/1000/gvfs-burn
prw------- 1 fp users 0 Oct 13 17:59 /run/user/1000/kalu_fifo_1058
drwx------ 2 fp users 120 Oct 13 17:59 /run/user/1000/keyring
drwx------ 2 fp users 80 Oct 13 17:59 /run/user/1000/pulse
drwxr-xr-x 2 fp users 80 Oct 13 17:59 /run/user/1000/systemd
Comment by Frank Phillips (fphillips) - Wednesday, 14 October 2015, 23:25 GMT
After marking /run/user/1000/gvfs owner-writable, my Google Drive mounted. Then after unmount/try to remount I found it read-only again.
Comment by Oscar Garcia (ogarcia) - Thursday, 15 October 2015, 07:33 GMT
The permission level of gvfs is read only for user:

$ ls -l
total 0
srw-rw-rw- 1 ogarcia ogarcia 0 oct 14 11:43 bus
drwx------ 2 ogarcia ogarcia 60 oct 15 09:27 dconf
drwx--x--x 2 ogarcia ogarcia 60 oct 14 11:43 gdm
drwx------ 2 ogarcia ogarcia 60 oct 14 11:43 gnome
drwx------ 3 ogarcia ogarcia 60 oct 14 11:43 gnome-shell
dr-x------ 2 ogarcia ogarcia 0 oct 14 11:43 gvfs
drwx------ 2 ogarcia ogarcia 40 oct 14 12:11 gvfs-burn
drwx------ 2 ogarcia ogarcia 120 oct 14 11:43 keyring
drwxr-xr-x 2 ogarcia ogarcia 60 oct 14 11:44 ownCloud
drwx------ 2 ogarcia ogarcia 80 oct 14 11:43 pulse
drwxr-xr-x 2 ogarcia ogarcia 80 oct 14 11:43 systemd

$ ls -ld gvfs
dr-x------ 2 ogarcia ogarcia 0 oct 14 11:43 gvfs

But you can read the contents without problems.

$ ls -la /run/user/1000/gvfs
total 0
dr-x------ 2 ogarcia ogarcia 0 oct 14 11:43 .
drwx------ 12 ogarcia ogarcia 260 oct 14 13:30 ..

Even so you can't mount any network shares.
Comment by Alexander Kempen (chron) - Thursday, 15 October 2015, 17:56 GMT
Same problem but with sshfs here.

Connection to the server works fine, but nothing is actually being mounted to /run/user/1000/gvfs/


Until it's fixed I'll just have to mount stuff by hand.
Comment by Sébastien Luttringer (seblu) - Thursday, 15 October 2015, 22:13 GMT
not fixed with the last gvfs version (1.26.1.1-1).
Comment by Andy Pastuszak (apastuszak) - Friday, 16 October 2015, 03:38 GMT
I am now able to mount shares samba and NFS shares in Nautlus. I cannot mount Owncloud or Google Drive shares. Those throw a dialog box up that says "Volume doesn't implement mount."
Comment by Sébastien Luttringer (seblu) - Friday, 16 October 2015, 12:13 GMT
are you able to get a VFS path with your mounted samba/nfs? In means you are able to list your remote shares through $XDG_RUNTIME_DIR/gvfs ?
Comment by Dimitris Chrysostomou (DimitrisC) - Friday, 16 October 2015, 16:08 GMT
Downgrading to gvfs version 1.26.0-3 as temporary workaround as I can confirm that the issue still exists (cannot view my NAS shares) in the latest version (1.26.1.1-1).
Comment by Sebastian Jug (jugs) - Friday, 16 October 2015, 19:18 GMT
I have the same issue with SMB shares, cannot view in the /run/user/1000/gvfs but I can see them in thunar directly.
Comment by Norbert Fuksz (Fuxy) - Saturday, 17 October 2015, 15:31 GMT
I'm using cinnamon but I think this may be related/relevant so I'm posting it here.

I have gvfs 1.26.1.1-1 installed and using Nemo I an unable to browse the network.

I am however able to go directly to the network share with 'smb://hostname/share' but when I'm trying to access the files in VLC or Audacious they complain that the folder doesn't exist and uppon further search is does seem that the share is not mounted in '/run/user/1000/gvfs'.

I have managed to narrow it down to if I 'killall gvfsd gvfsd-metadata gvfs-udisks2-volume-monitor' (notice i did not use sudo) and start them at the terminal by running '/usr/lib/gvfs/gvfsd', '/usr/lib/gvfs/gvfsd-metadata' and '/usr/lib/gvfs/gvfs-udisks2-volume-monitor' it will work correctly.

This is wierd because htop shows the above running with my user permissions so me killing them and starting them manually should not do anthing but is seems like they did not initialize correctly on startup.
Comment by Jan Alexander Steffens (heftig) - Saturday, 17 October 2015, 23:56 GMT
Those that have this issue with gvfs >= 1.26.1, could you please compare the output or "tr '\000' '\n' </proc/PID/environ" for the PIDs of your systemd --user and your dbus-daemon?
Comment by Norbert Fuksz (Fuxy) - Sunday, 18 October 2015, 01:17 GMT
tr '\000' '\n' < /proc/751/environ

LANG=en_GB.UTF-8
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
NOTIFY_SOCKET=/run/systemd/notify
HOME=/home/fuxy
LOGNAME=fuxy
USER=fuxy
SHELL=/bin/bash
MAIL=/var/spool/mail/fuxy
XDG_RUNTIME_DIR=/run/user/1000

sudo tr '\000' '\n' < /proc/808/environ

SHELL=/bin/bash
DBUS_STARTER_ADDRESS=unix:path=/run/user/1000/bus,guid=08842ecae0728f253f83abc65622d0c6
DISPLAY=:1
XDG_RUNTIME_DIR=/run/user/1000
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
MAIL=/var/spool/mail/fuxy
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus,guid=08842ecae0728f253f83abc65622d0c6
USER=fuxy
XAUTHORITY=/run/user/1000/gdm/Xauthority
DBUS_STARTER_BUS_TYPE=session
LANG=en_GB.UTF-8
MANAGERPID=751
HOME=/home/fuxy
LOGNAME=fuxy

sudo tr '\000' '\n' < /proc/784/environ

DISPLAY=:1
HOME=/home/fuxy
LANG=en_GB.UTF-8
LOGNAME=fuxy
MAIL=/var/spool/mail/fuxy
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
SHELL=/bin/bash
USER=fuxy
XAUTHORITY=/run/user/1000/gdm/Xauthority
XDG_RUNTIME_DIR=/run/user/1000
MANAGERPID=751
LISTEN_PID=784
LISTEN_FDS=1
LISTEN_FDNAMES=dbus.socket

This is what I got for my user. Couldn't do it for the PID's of other users like gdm and dbus.




Comment by Jan Alexander Steffens (heftig) - Sunday, 18 October 2015, 02:50 GMT
Er, which PID is which? And was this indeed done with gvfs 1.26.1? You should reboot after installing gvfs so that any remnants of gvfs 1.24 are gone.
Comment by Norbert Fuksz (Fuxy) - Sunday, 18 October 2015, 04:40 GMT
Did as instructed reinstalled latest gvfs and rebooted. This is what I got.

systemd --user

LANG=en_GB.UTF-8
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
NOTIFY_SOCKET=/run/systemd/notify
HOME=/home/fuxy
LOGNAME=fuxy
USER=fuxy
SHELL=/bin/bash
MAIL=/var/spool/mail/fuxy
XDG_RUNTIME_DIR=/run/user/1000

dbus-daemon --config-file=/etc/at-spi2/accessability.conf --nofork --print-address 3

SHELL=/bin/bash
DBUS_STARTER_ADDRESS=unix:path=/run/user/1000/bus,guid=b9290b75836113c5947d211056232047
DISPLAY=:1
XDG_RUNTIME_DIR=/run/user/1000
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
MAIL=/var/spool/mail/fuxy
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus,guid=b9290b75836113c5947d211056232047
USER=fuxy
XAUTHORITY=/run/user/1000/gdm/Xauthority
DBUS_STARTER_BUS_TYPE=session
LANG=en_GB.UTF-8
MANAGERPID=750
HOME=/home/fuxy
LOGNAME=fuxy

dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation

DISPLAY=:1
HOME=/home/fuxy
LANG=en_GB.UTF-8
LOGNAME=fuxy
MAIL=/var/spool/mail/fuxy
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
SHELL=/bin/bash
USER=fuxy
XAUTHORITY=/run/user/1000/gdm/Xauthority
XDG_RUNTIME_DIR=/run/user/1000
MANAGERPID=750
LISTEN_PID=783
LISTEN_FDS=1
LISTEN_FDNAMES=dbus.socket
Comment by Jan Alexander Steffens (heftig) - Sunday, 18 October 2015, 05:55 GMT Comment by Jan Alexander Steffens (heftig) - Sunday, 18 October 2015, 06:48 GMT
Please test with dbus 1.10.0-4 from [testing].
Comment by Matej Špindler (MatejSpindler) - Sunday, 18 October 2015, 09:55 GMT
With dbus from testing sftp and smb mounts work as exacted.
Comment by Norbert Fuksz (Fuxy) - Sunday, 18 October 2015, 14:41 GMT
I can confirm dbus 1.10.0-4 update fixes it.
Comment by Tomasz Borkowski (Tomasz) - Monday, 19 October 2015, 17:59 GMT
I can also confirm that dbus1.10.0-4 update fixes the issue.
Comment by Gerhard Bogner (slashME) - Wednesday, 21 October 2015, 12:47 GMT
Even with the dbus update I still can't mount ssh/sftp from /etc/fstab (using sshfs as fs type), while mounting from "connect to server" kind of works: it connects to the host, but ignores the path passed after the server name.

Mounting from command line (mount /path/to/mountpoint) works as expected.
Comment by Thymo van Beers (Thymo) - Wednesday, 21 October 2015, 22:06 GMT
Relaunching the daemon seems to resolve the issue on MATE. Might also work on GNOME 3.18.
Comment by Rome R. (mDuo13) - Friday, 23 October 2015, 06:26 GMT
After upgrading to the dbus from testing, I can navigate to smb:// addresses and open files again; however, I still cannot browse (as in, see a list of) my local network shares with Thunar, which used to work.

For the record, the smbtree command DOES list the shares correctly.
Comment by Oscar Garcia (ogarcia) - Friday, 23 October 2015, 07:45 GMT
I can confirm that with dbus 1.10.0-4 the issue is complety fixed.

Can navigate un smb:// ssh(sftp://) google-drive:// and davs:// without problem.
Comment by Sébastien Luttringer (seblu) - Friday, 23 October 2015, 11:43 GMT
Yes, it's fixe. Thanks Jan. I think you can close.

Loading...